2

I am successfully using Curtain mode on Chrome Remote Desktop on my Windows 7 Ultimate installation, and I have been recently trying the new Windows 10 beta to see what might not work when I upgrade.

I know Windows 10 is a beta, so I understand there are some things that simply won't work as a beta could have bugs.

I have found that when I try and use Chrome Remote Desktop on Windows 10, it works fine with it's default installation, but when I try and enable curtain mode, I get a blanks screen and then shortly disconnected after entering the PIN. Does anyone know how to get this working?

I included Windows 8 in the tag as it's possible there might be a similar issues there as it seems to me Windows 10 is more similar to Windows 8 than Windows 7, but I don't have access to Windows 8. If it's not possible to get it to work in Windows 8 either, then I suppose I don't have much hope for windows 10.

1

Solution to this problem is described in comment 27 on page https://bugs.chromium.org/p/chromium/issues/detail?id=506555

Answer from comment 27:

"I have a root cause for this. The default value for the RDP-TCP Security Layer has changed for Windows 10. RDP connections use either SSL(TLS) or RDP-SL and the default value on previous Windows versions is 'negotiate' (i.e. allow client to dictate the connection security type). On my fresh Windows 10 install, this value was set to SSL(TLS) which we don't support. Changing it back to negotiate fixed the problem. I couldn't find a consistent UI to change the setting (it exists on server but I didn't see it on client OSes) so the most consistent way to get this working again is to set the Security Layer registry key back to 'negotiate' which mirrors the behavior on previous OSes. Registry Key: \HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp\SecurityLayer The value I expect for these failures is 2, which correspeonds to SSL(TLS). Change this value to 1 (negotiate). No reboot is necessary, you can try establishing a CRD connection immediately."

This solution worked for me and others.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.