I'm using the Bose QuietComfort 15 headphones with the built in microphone and I'm plugging it into a laptop that has a jack that supports the mic & speaker at the same time. By default, I can't hear my own voice which is very annoying. I found two different ways to hear myself through the headphones.

  1. Go into the Recording Devices, Open the Microphone properties, Click the Listen tab, and listen to the microphone.
    • I can hear myself, but there is a terrible delay which makes this option unusable. listening to microphone
  2. Go into the Playback Devices, Open the Speakers/Headphones properties for the Bose headset, click the Levels tab, and unmute and turn the microphone and volume all the way up.

    • I can hear myself without a delay, but only with the volume all the way up. If I'm using an app like Join.me, I can turn the app volume down to compensate, but if I get an email or something that causes a Windows sound it's so loud that it hurts my ears. adjusting levels in playback

Is there another way to hear myself without having the volume all the way up?

  • Just adding some expressions I Google'd in hopes they'll boost search score for this answer, which fixed my issue. Sorry, I did search vendor-specific terms, only to realize this is not a vendor-specific issue. "Jabra Speak 410 feedback, echo, cancel echo, hear myself in my desktop set, speakerphone, squeal" May 19, 2017 at 22:35

2 Answers 2


I don't know if you ever found an answer since the questions is 3+ years old. But for posterity sake (and for anyone trying to get an answer) here you go:

Software wise, no there isn't any other options.

The problem being is that anything that your computer has to process and then send back to you (even as simple as a microphone input) will have the slightest amount of delay, causing that annoying thing where you mentally just start talking slower because your brain is trying to compensate for the delay. ... maybe that's just me.

I don't know the technical reasons, but if I had to make a guess, it would have to be the processing of analog to digital and then back to analog

But if you absolutely need that feedback, you can purchase a mixer. Here is a good list:

  1. Behringer UM2 - $29.37 (http://a.co/d/ckZlVPC)
  2. Any headset splitter - ~$7.00
  3. Two (2) x Any 3.5 mm to 1/4 inch stereo adapter. - 3 pack ~$7.00


  1. Plug in the 3.5mm to 1/4 inch adapters into both the headphone port (directly underneath the Behringer logo) and the 'Inst 2' (Instrument 2) port on the Behringer UM2
  2. Plug in the Microphone end of the headset splitter into the adapter that is connected to the 'Inst 2' port
  3. Plug in the Audio end of the headset splitter into the adapter connected to the Headphones port
  4. Plug your headset into the headset splitter.
  5. Plug in the Mixer into a spare USB port on the computer.
  6. Click the "Enable Direct Monitor" button on the mixer.

You should now have a 'zero latency' monitor of your headphones directly into your headset.

Just as a note, this allows you to have two points of control for your microphones volume. Both on the mixer itself, and inside of windows.

Hope this helps!!!


If anyone else has this problem please check if you have a Realtek HD. If you do, go to voice control, select your mic and something like playback volume should be there. On the right is a mute button, press it and it should work, and it doesn't have any delay

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .