17

I have a folder with no name on my Windows desktop. The name is literally empty:

enter image description here

I'd like to get rid of this. Oh, easy you say? Well here's where things get interesting. First, if I click on it and hit Delete, it just comes back within a day, like a zombie coming back from the dead.

Okay, great maybe I can hide it or something. Well, if I try to right click on it to modify the folder properties, it becomes clear this isn't actually a real file:

enter image description here

If I select "Create shortcut", nothing happens. If I double click on it to try to open it, nothing happens. What does the actual file system look like, you ask? Nothing:

enter image description here

Any ideas on how to kill this thing once and for all?

Update:

Contents of desktop.ini:

[LocalizedFileNames]
migwiz.lnk=@%windir%\system32\migwiz\wet.dll,-588

Contents of Public folder desktop.ini:

[.ShellClassInfo]
LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21799

Another Update:

I can Cut the folder and paste it somewhere else on the desktop. If I paste the folder to some other folder on my disk, I get this helpful error:

enter image description here

  • 1
    If you have a look inside desktop.ini you may see the definition of the "folder". This happens after a restart? Or even if you leave the system running? – Julian Knight Jun 24 '15 at 20:56
  • 1
    Try dir /ah C:\Users\Public\Desktop – Steven Jun 24 '15 at 21:01
  • @Steven - Same thing. Just one desktop.ini hidden file (no normal files) – Mike Christensen Jun 24 '15 at 21:07
  • @JulianKnight - Added the contents of both desktop.ini files to the post. – Mike Christensen Jun 24 '15 at 21:09
  • 1
    I don't like to be a naysayer but ... no AV is perfect. You should check manually for odd things running and maybe run some anti-malware checks too. – Julian Knight Jun 24 '15 at 21:22
18

According to this discussion, this issue seems to be related to remnants of an old Microsoft Office 2010 installation.

http://www.sevenforums.com/general-discussion/256250-random-empty-folder-keeps-appearing-desktop.html

The fix suggests searching the registry for 138508BC-1E03-49EA-9C8F-EA9E1D05D65D and removing occurrences.

| improve this answer | |
6

Going to

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\

and removing these keys:

138508BC-1E03-49EA-9C8F-EA9E1D05D65D

0875DCB6-C686-4243-9432-ADCCF0B9F2D7

appears to have taken care of this bizarre problem.

| improve this answer | |
  • 2
    Would be nice if what these keys did were documented somewhere. Removing keys with arbitrary/cryptic GUIDs seems scary. – Journeyman Geek Jan 9 '17 at 0:31
0

Had the same error here. Not a folder icon though but an empty file icon.

Did a full system scan for malware / virus: Nothing.

I then deleted the two regdb keys as mentioned in the suggestion/tip above and the problem went away immediately.

Deleted entries

  • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace{0875DCB6-C686-4243-9432-ADCCF0B9F2D7}] @="Microsoft OneNote Namespace Extension for Windows Desktop Search"

  • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace{138508bc-1e03-49ea-9c8f-ea9e1d05d65d}] @="MAPI Shell Folder"

| improve this answer | |
0

I also had Office 365 (2015+) click-n-run and Office 2010 installed. Office 365 was uninstalled, Office 2010 is still running on the system. PC running windows 10.

To fix search/run on your PC for

regedit

Backup your registry or the class you are editing. I fixed the issue using this solution but you can also remove the key found by trying to move the foder and getting the ID from the error message (as described in the problem description - Another Update) between the curly brackets ::{xx_ID}

In my case the issue was in:

[HKEY_USERS\{your-user-sid}\Software\Microsoft\Windows\CurrentVersion\Explorer\CLSID]

After removing those keys I deleted the icon from desktop and restarted.

The icon is gone.

| improve this answer | |
0

Please open registry and find this path..

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\

Then find the name without any value. Usually this one {138508BC-1E03-49EA-9C8F-EA9E1D05D65D} has not set any value. Please delete that entry by right-clicking and delete.

| improve this answer | |
-1

1.Uninstall the Microsoft office.

2 Delete the "office" files from C:\ProgramData\Microsoft

3.Rename the the file Microsoft Help as "Microsoft Help.old" from C:\ProgramData

4.Restart the system

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.