1

According to the man page for byobu, entering F9 while in byobu should bring up the "Configuration Menu." However, I'm using SSH to connect to the Linux box, so I need to enter the escape sequence for F9, rather than pressing the F9 key itself.

As I described here, I used the suggested method here to determine the escape sequences for F1-F12 on my platform (Ubuntu 10.04.4 LTS). As I described here, I found (among other things) that the escape sequence for F9 is ^[Ow.

My question is, how do I enter ^[Ow in the terminal?

I start byobu by entering:

byobu

Then I type Ctrl+V, followed by Esc, which enters ^[. Then I type Shift+O (capital "O"), followed by W (lowercase "w").

In other words, my keystrokes inside byobu are these:

Ctrl+V

Esc

Shift+O

W

I obtain ^[Ow and press Enter. However, I get this error:

w: command not found

Evidently, I am entering the escape sequence incorrectly. What keystrokes must I use to enter it correctly?

(Note: I am using SSH Secure Shell (now called Tectia SSH Client), not PuTTY, to connect to the Linux box via SSH.)

1 Answer 1

0

The apparent problem is that you are typing Ctrl+V before the Esc key.

Control/V is usually the lnext (literal-next) character, which tells the terminal driver to not do anything special for the following character. That lets it pass through to the application (or shell) which ignores it, and likewise the Capital/O likewise is ignored (or legal in some sense). The application finally notices a problem on Lower/w, for whatever reason.

By the way, the method used for determining the key sequences is relying on a particular setting of the TERM environment variable, which the application uses to look-up in the terminal database. (It probably is vt100). You could in principle set it to another value (one whose terminfo entry has 12 function keys) and send the corresponding escape sequences using the same method.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .