I have a dual-monitor setup in my notebook, which is running Arch Linux with Gnome 3 as Desktop Environment.

My graphic card is Intel HD Graphics 3000 and my external monitor (VGA1) is a Philips 202EL, which best resolution is 1600x900.

I've tried to run the following commands:

$ cvt 1600 900
$ xrandr --newmode "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync
$ xrandr --addmode VGA1 1600x900_60.00
$ xrandr --output VGA1 --mode 1600x900_60.00

As result, the external monitor screen blinks, but the resolution is not changed. I've tried to run with gtf instead of cvt as well, but with no luck.

Is there something I am missing? Is there any alternative way to fix my monitor screen resolution?

  • Why are you not executing xrandr using sudo? A very good tutorial is here.
    – harrymc
    Mar 1, 2019 at 15:14
  • Any answer to my comment? Felipe Arenales? Shinra tensei?
    – harrymc
    Mar 3, 2019 at 21:31

2 Answers 2


You can directly edit the xorg.conf after you generate one. Take a look at this thread: http://bbs.archbang.org/viewtopic.php?id=14


I think that your xrandr calls are not effective since you are not running them as elevated root.

You should run the calls as:

sudo xrandr ...

A very detailed tutorial with screenshots on using xrandr can be found in the Ubuntu Handbook article: How to Set A Custom Screen Resolution in Ubuntu Desktop.

  • Comment by Shinra tensei: I am sorry for having to comment like this, as you can see my reputation points dropped to 1 because of the bounty and I'm simply unable to comment at all. My answer is no, this does not work. I have to say it worked with and without sudo before the day this started to fail, and it still works now, it's just that now the resolution doesn't stay as set with xrandr, but instead it reverts after a very short amount of time. But the command worked and still works, and it doesn't throw a permission denied message or anything without sudo, so using it is not the solution.
    – harrymc
    Mar 7, 2019 at 15:08
  • @Shinratensei: Do you have installed any automatic display setting product such as redshift or Ubuntu's 'Night light' feature?
    – harrymc
    Mar 7, 2019 at 15:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .