0

I cannot insert carets and backticks (and possibly other characters) in XTerm under certain conditions. When I move focus from XTerm to Firefox and use Alt+Tab to switch back, I can no longer instert ^ and `.

Strangely enough, I can only reproduce the problem by Alt+Tabbing from Firefox to XTerm, other applications don't seem to cause the issue. From what I've tried, it really is the act of tabbing into the XTerm, tabbing to Firefox and clicking back works just normally.

I am running XTerm(297) on Ubuntu 14.04.2 LTS. I'm using a German keyboard layout, so I have to follow carets and backticks by a space to make them appear alone. With this issue, pressing the backtick/caret key does simply nothing at all, and the following space inserts a space. When I use a US keyboard layout for testing, everything works fine too.

Please help me solve this mystery.

0

Here's a guess: the Alt+Tab back to xterm does not really place the focus inside the VT100 window.

Even one pixel off can produce a problem when you have composed keys, e.g., between scrollbar and the VT100 window.

xterm adds key-translations to allow you to type "anywhere" on its overall window, but the XIM code does not allow multiple windows to act as its input. There have been a couple of bug-reports related to moving the cursor across that gap. A related issue was reported in Debian Bug report logs - #721523 xterm: XIM preview position incorrect

(There is no easy fix for this scenario).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.