5

I have two tablets; a Surface Pro 3, and a very cheap HP Stream 7. When I leave the SP3 alone for a whole day, I usually come to it and find that it's turned itself off, or gone into Hibernate mode. This is fine by me, because as a result I can leave it in a "maybe I'll need it in a minute" mode and not have to worry about shutting it off to conserve battery.

The Stream 7, though, is not so lucky. It will stay "on" to some degree even after 30+ minutes of inactivity; such that if I don't manually shut it down, then it will definitely have a dead battery when I come back to it.

I've looked in Power Options>Advanced, but it seems like some commonly-mentioned menus don't appear for either of them. There's no [+]Sleep, just "Balanced", "Desktop Background settings", "Power buttons and lid", "Display" and "Battery", none of which seem to be what I'm looking for. For all relevant settings I know of, the SP3 and Stream seem to share settings.

Any suggestions as to how I could make Windows hibernate (or simply shut down) after it's been abandoned?

  • It's possible you have InstantGo activated. Can you post the output of powercfg /a? Run that from a command prompt running as administrator. In case you don't know how to get an admin command prompt: On the Start screen, start typing “command prompt” (without the quotes). The Search panel displays on the right side of the screen and results of the search display as you type. Right-click on Command Prompt and select Run as administrator from the popup menu. – Valentin Jun 28 '15 at 14:22
7
+50

For some reason, the power plan on many tablets has been severely reduced to a few options. As a result, you'll have to make the hibernate-on-idle task manually in Task Scheduler.

Step 1: Open Task Scheduler.

Step 2: Go to Action > Create Task...

Step 3: In General, name your task and check Run whether or not user is logged on or not and Run with highest privileges.

Step 3

Step 4: Go to the Triggers tab. Add a trigger that begins On idle and check Enabled.

Step 4

Step 5: Go to the Conditions tab and check Start the task only if the computer is idle for: 30 minutes. If it's not working as expected, fiddle a bit with this area. On the Power area, uncheck Start the task only if the computer is on AC power.

Step 5

Step 6: Go to the Actions tab and create a new task with the program being shutdown and the arguments -h.

Step 6

Step 7: Click OK on the Create Task dialog.

Step 8: Wait 30 minutes, and your device should hibernate. If not, you'll be sure to find any errors in the Event Log.

That's it!

  • 1
    The "for some reason" you speak of is because of Microsoft/Intel pushing their always-on "connected standby" features. – qasdfdsaq Jul 2 '15 at 14:57
  • @qasdfdsaq Yeah, I read a bit about that. Could include some other reasons as well too, like OEMs turning this off manually to make power management "simpler." – oldmud0 Jul 2 '15 at 15:37
1

click on power > more power options > change plan setting > change advance power setting that's it If you can't find any of these or you can't find hibernate update your graphic card driver

for win8 You'll need to access your system's power settings, which you can do any number of ways. My preferred method: press Win-W (that's the Windows key and the letter w) to bring up the Settings Search menu, then type power.

Click Change what the power buttons do.

Click Change settings that are currently unavailable.

Scroll down to the bottom of that window to find the "Shutdown settings" section.

Click the box next to Hibernate to enable the option.

Click Save changes.

Now, when you go to power down your system, you'll see the Hibernate option in your list of choices. Also, in that same System Settings window (step 4), you can choose Hibernate for any of the "Power and sleep buttons and lid settings" options.

  • The suggestion to update my graphics driver sounds useful; but I doubt there are ever updates for whatever goes with an Intel Atom processor, and they should have come through Windows Update. As for the Power Settings, I do not have the "Shutdown settings" section, even when I click the "Change settings that are currently unavailable" link. – Katana314 Jun 26 '15 at 16:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.