2

VMWare workstation has a feature to share VMs. To use this feature VMware Workstation Server should be running, and it should be running by a default installation configuration. However in my case This feature won't run its service vmware-hostd and any manual start of this service results in immediate stop.

Review on the log file at C:\ProgramData\VMware\hostd\hostd-##.log shows two significant notes:

  • 2015-06-26T03:52:54.543+04:30 [05264 error 'Default'] An error occurred while loading configuration "C:\ProgramData\VMware\VMware Workstation\ft-vmk-version.ini",not all entries are being read. It is strongly encouraged that you manually inspect the file and fix any corruptions.

  • 2015-06-26T03:52:55.570+04:30 [05264 info 'Solo'] HostdCommon::CreateAndBindServerSocket: soapPort: 8307 2015-06-26T03:52:55.574+04:30 [05264 info 'Default'] Win32 service stopped

Of these two my guess is the second one trying to pinpoint the problem. My guess is based on running the service manually using this command:

C:\Program Files (x86)\VMware\VMware Workstation>vmware-hostd.exe -u "C:\Program Data\VMware\hostd\config.xml" > d:\a.log

which produces this output on stdout:

error: Resource is already in use: <acceptor p:0x053a38b0, h:1148, <TCP '[::1]:8307' >>
backtrace:
backtrace[00] rip 5626d483
backtrace[01] rip 5614eb34
backtrace[02] rip 5614fbb1
backtrace[03] rip ...

I've double checked for any process running on port 8307. There is no such process.

sidenote: I've installed VMware workstation on another machine, but everything was OK there...

5

Just go into C:\ProgramData\VMware\hostd folder and delete the datastores.xml FILE. The service will start fine after that...

| improve this answer | |
  • This worked for me. Seems like the original datastores.xml file was corrupt. – TryHarder Oct 25 '16 at 0:34
  • My datastore.xml was 3 years old and empty. So yes, deleting it and choosing a new Shared VM directory fixed it. – Richard Feb 2 '17 at 16:28
  • Worked for me. Just delete it was enough – LCoelho Jun 11 '19 at 11:00
2

So I found the culprit. I had proxifier software which routed custom packets into a given socks proxy. I don't know how it denied vmware workstation to startup the shared VM service, but I'm completely sure the problem was originated from this software.

| improve this answer | |
0

Have you got the same admin rights on your workstation? Try to remove the software and install it newly with admin rights. It looks like some component are not working very well, so maybe a new install or update can fix your issue.

| improve this answer | |
  • I uninstalled vmware, removed all of its remaining configurations manually and installed again. No difference... – Klaus Jun 26 '15 at 10:45
  • Can you attach the log file after a clean install? I can check the issue and maybe we can found a solution. – garybsimon Jun 26 '15 at 11:09
  • here it is – Klaus Jun 26 '15 at 12:29
0

I had the same issue where the service would not start, I deleted the datastores.xml, removed and reinstalled several times with different versions of Workstation from 12-12.52 and nothing. Just randomly I changed the HTTPS port for sharing to any other number and Sharing and the Server Service started right up...

| improve this answer | |
  • That is quite probably another valid approach- can you outline briefly how you changed the HTTPS sharing port? – bertieb Feb 16 '17 at 14:51
-1

I had a similar issue. VMwareHostd didn't start up even though 'Automatic' was selected. The Windows Event log said:

The VMwareHostd service depends on the VMUSBArbService service which failed to start because of the following error: 
The system cannot find the file specified.

VMUSBArbService also wasn't started, even though 'Automatic' was selected. It seemed something was stopping VMUSBArbService from accessing a file. I suspect it was my BitDefender Antivirus, but I couldn't verify that assertion.

The solution was to create a scheduled task along the lines described in this SU answer. For the action I executed net start from the command line. Program/script: C:\Windows\System32\cmd.exe, Add arguments: /C "net start VMwareHostd". I scheduled the task to run as logon after 10 seconds (1s failed).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.