8

To prevent Windows from adding the word "shortcut" to shortcut names, I've always set the Link value to 00 00 00 00 in the following registry key:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer

I find this no longer works in Windows 10.

Even after logging off and even restarting, Windows 10 goes right on adding the word "shortcut". Furthermore, it changes Link back from 00 00 00 00 to other values such as 17 00 00 00.

This registry tweak has always worked before, going right back to Windows 95 & 98, through Windows Vista & 7 and Windows 8.

I'm on the latest version of Windows 10 that's successfully come to my machines (April tech preview, build 10074).

I've searched but can find nothing about this.

How can we stop Windows 10 from adding the word "shortcut"?

5
  • The latest build is 10130, although I don't know if the shortcut registry tweak wil work in that. – Andrew Morton Jun 27 '15 at 19:16
  • I tested and it does work in build 10130, but apparently only for shortcuts created after the registry tweak. – Andrew Morton Jun 27 '15 at 21:15
  • @Andrew, cool, I'll look forward to that when the update to build 10130 succeeds for me. The update's currently still failng on my machines. (It's always been only for shortcuts created after the tweak, as it kicks in at the time they're created--though in fact it would be better if it was only a reference, and used to at the time of display, so the change would then apply retrospectively...). Suggest you put this as an answer then. – Reg Edit Jun 27 '15 at 21:26
  • I tried it on Windows 8.1 and it's didn't work. Still no results after restarting explorer.exe. – user373230 Jun 28 '15 at 1:58
  • 1
    @Elvin that's a pain--it works on 8.1 for me. (You do have to log off, not just restart Explorer.) – Reg Edit Jun 28 '15 at 9:14
6

The registry tweak of setting Link to zero in HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer works in Windows 10 Technical Preview build 10130.

I do not know if it will work in build 10074 or if there is some anomaly on your copy which is causing it to revert, which could conceivably be connected to your machine not updating to the current build.

1
  • 2
    Rather than wait any longer for my existing preview boxes to sort themselves out with their failing updates, I did a direct install of build 10130 on a new VM. The registry tweak does indeed work on that one. (However, it didn't work until I restarted the machine. A logoff was not sufficient to pick up the registry change. I'm sure that's a change from previous Windows versions, though perhaps it too will be resolved in an upcoming build.) – Reg Edit Jun 28 '15 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.