2

I'm using Lubuntu 14.10 and trying to change the default window manager to awesome.

I installed awesome with:

sudo apt-get install awesome

Per the awesome wiki, I tried editing the ~/.xinitrc file to have the contents:

exec awesome

But after logging out (and rebooting) this isn't working.

Isn't there an rc file somewhere that I can edit?

My current need is for the awesome wm, but I was hoping there was a general way of doing this for any window manager.

4
  • When you say "this isn't working", do you mean Openbox is still your WM? Have you modified lubuntu's autostart? Have you tried openbox --replace? Doesn't awesome show up as a choice at login? – DK Bose Jun 29 '15 at 1:22
  • Yes, "not working" means that Openbox is still the wm. I wasn't aware of an "autostart" feature that can be altered. Will google that tonight. – Jonathan.Brink Jun 29 '15 at 12:36
  • 1
    Well, if you have a relatively vanilla Lubuntu, you should see it by clicking on Lxpanel's menu and choosing Preferences > Default applications for LXSession. While I use Lubuntu 14.04.02 myself, I log in to the Openbox session (just Openbox) rather than into the Lubuntu session (LXDE + Openbox). – DK Bose Jun 29 '15 at 13:13
  • 1
    @DKBose thanks... "Default applications for LXSession" worked by entering "awesome" and logging out/back in – Jonathan.Brink Jun 29 '15 at 23:07
0

if You log out, after entering your login-name to log in again, you can chose the wm to use (probably right above your name, not sure because I do not use Lubuntu, but it is there somewhere). If you chose a wm that is not the default, you will get a notification asking you if you want to set it as your default and next time if you boot up your system you will have awesome.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.