My S/PDIF digital output used to work fine - stereo, DD, DTS, etc. However after upgrading my Mythbuntu 9.10 64 bit install to use the Nvidia 190 driver, I lost my SPDIF audio. In trying to fix it I've tried dozens of things ranging from the typical to the far-fetched, but none of them have worked.

Analog sound works fine, and "aplay -l" says my SPDIF device is right where it should be (see below). So the failure seems to be at a lower level than the typical alsa problem. Here is some info (I'll add more on request):

  • I believe I've covered all the common causes for this problem (S/PDIF disabled in alsamixer, etc.), but I could have missed something stupid so feel free to ask.
  • To try to simplify the problem, I've removed PulseAudio. (I've also tried the opposite - to get PulseAudio working - no dice.)
  • I upgraded to alsa and then to I played around with those and couldn't get it to work, so I reinstalled from the mythbuntu 9.10 repository. Last night I compiled the Realtek linux driver, so I'm now running 1.0.21-r5.13rc9.
  • "aplay -l" output:
    card 0: Intel [HDA Intel], device 0: ALC889A Analog [ALC889A Analog]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 1: ALC889A Digital [ALC889A Digital]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
  • Ubuntu is using ALC889A, but I actually have an ALC885. I believe the same HDA driver is used for both, but just in case...
  • When the system boots, the Ubuntu boot sound coming out of the analog output sounds like it's playing 2 copies of the Ubuntu boot sound, staggered by a second or so. ??? (Maybe a clue to what's hosed? Is it launching some sound-related program multiple times?)
  • When I run "speaker-test -Dplughw:0,0 -c2" - I hear the pink noise
  • When I run "speaker-test -Dplughw:0,1 -c2" - I don't hear noise.
  • The red light at the end of the spdif cable lights up when I enable S/PDIF, turns off when I disable S/PDIF.

The last three bullets plus the perfectly normal "aplay -l" results despite multiple ALSA versions and reinstallations are why I'm baffled. It used to work, I'm sure it can be made to work again, but I'm totally stuck at this point...

2 Answers 2


i had the same problem, the solution that worked for me:

1) type into terminal: sudo gnome-control-center

2) then in the window that opens, click on the "Sound" icon

3) then go to "Hardware" tab, and change the "Settings" to one of the "Analog" options, and it works fine!


I ignored the most basic, simplest rule of debugging: verify your basic assumptions. I assumed my A/V receiver couldn't be the problem because it was brand new, it was working fine before I upgraded the video driver (and it has nothing to do with the video driver), and I hadn't messed with any of its settings. So in all the hours I spent troubleshooting, I never verified that the receiver was still working with an optical input. Tonight I plugged the s/pdif from my Ubuntu system into the optical input for the CD, and it worked. My receiver had somehow scrambled the connection for the original optical input. I played with the receiver preferences (switching the input source to HDMI and then back to optical) and now it works again.

Live and learn (again)...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .