0

I have a Kingston USB drive and I want to format it but I can't do it. I've already tried the disk management and the diskpart but it won't work. Whenever I would format it, there will be a window that will appear saying that Windows can't format the disk. What should I do?

  • Have you tried it from the CLI using administrative privileges? Try something like: format <drive letter>: /q /u /v – Jeroen Jun 30 '15 at 7:14
  • include a screenshot and try rufus. I've found sandisk better than kingston anyway, fod speed and so maybe reliability, maybe it is faulty too. Try rufus anyway. and twhat jeroen said – barlop Jun 30 '15 at 7:16
  • Does it show 0 total space and 0 free space ? If so, you can throw it away. Otherwise it may be recoverable. – Overmind Jun 30 '15 at 11:41
  • Kingston has a format utility program. Have you tried that? – rrirower Jun 30 '15 at 12:57
1

try this in cmd.exe replace X for the disk number of your USB which is shown when you input list disk

diskpart
list disk
select disk X
clean
create part pri
select part 1
format fs=ntfs quick
exit
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.