29

Just like the title says, I'm trying to change the font size in Notepad++ to what it should be.

I don't know why it's so huge.

enter image description here enter image description here

18

You can check out the "Reduce" option in Settings > Preferences > General > Tab Bar (section).

In Notepad++ (6.5) the size setting for tab labels is in Settings > Preferences > Tab Settings, although this appears to be a setting for formatting within documents.

Hopefully one of those settings will help.

| improve this answer | |
  • 3
    "Reduce" seems to be what the asker is looking for. – MBraedley Jun 30 '15 at 19:01
  • 4
    I actually had to uncheck reduce to make it look more normal. It's still larger than the other screenshots I've seen. Could be my display resolution or something maybe. – Pie Jun 30 '15 at 19:26
  • 1
    The nuclear approach would be to uninstall / reinstall Notepad++. Everything should go back to defaults after the re-install. – ABashore Jun 30 '15 at 19:27
  • 4
    Err... "Tab Settings" is for setting the number of spaces inserted when you hit the Tab key, not the size of document tabs. – helrich Jul 1 '15 at 11:21
33

You can also change the size of font in Notepad++ by holding Ctrl + scroll with mouse wheel.

| improve this answer | |
  • 7
    +1 as this is very likely the original cause to OP's problem. – DLeh Jun 30 '15 at 19:53
  • 13
    CTRL + Scroll does not affect the size of the tab titles. It only affects the size of the editable regions. – ABashore Jun 30 '15 at 20:29
  • 2
    @DLeh Using Ctrl key and scroll wheel will not make the font size of the tab title explode in size! It only affects the display of the document text, not GUI elements. – Samir Jun 4 '16 at 11:38
  • 2
    I think the intent of the OP was to reduce the TAB font size, judging by the screenshots. Though your answer is correct, the question you are answering is different. Correct me if I'm wrong. – NoCatharsis Sep 28 '16 at 12:32
14

I'm trying to change the font size in Notepad++

This is done in the Style Configurator:

  1. Goto Menu > Settings > Style Configurator

  2. Set Font size

  3. Check Enable global font size

  4. Press Save & Close

enter image description here

| improve this answer | |
  • 3
    But only works because you checked Enable global font size . An important step I missed first time around :-) – Carl Witthoft Jul 14 '16 at 13:40
  • 2
    As I stated above, I believe you also are answering the wrong question based on the OP's screenshots. This issue appears to be addressing tab font size, and not text display size within the document. – NoCatharsis Sep 28 '16 at 12:35
  • 2
    @NoCatharsis <shrug>. Look at the tile of the question. I doubt whether the OP will come back to clarify. It's a bad question and anyone looking to change the document font size will find this answer. – DavidPostill Sep 28 '16 at 12:39
  • It's a badly formulated question for sure. Although this is a great answer, it doesn't really answer the question if we turn a blind eye to the way the author formulated it and if we try to read between the lines what the author really wanted to ask. (This is what tells computers and humans apart. Be human!) What's peculiar to me is that by enabling "global font size" you don't just get bigger document font size (user data), you also get bigger line numbers (UI element), but the tab font size (UI element) is unaffected (even if you disable the "reduce" option in General preferences). – Samir May 30 '19 at 11:30
0

The font size in the TAB bar TABS is controlled by the following WidgetStyle lines in the stylers.xml.

If you decide to edit your stylers.xml file to see if it will affect your Notepad++ tab bars, be sure to make a backup copy in case you mess up the xml and need to return to the original code file. Just be sure that there is a space between the last parameter and /> otherwise you may find that something else broke and Notepad++ is not listening to your instructions.

Just to be clear; I did not find the following modifications to have an affect on the text size of the TAB BAR.

The 4 lines to edit are as follows:

    <WidgetStyle name="Active tab focused indicator" styleID="0" fgColor="FAAA3C" />
    <WidgetStyle name="Active tab unfocused indicator" styleID="0" fgColor="FFCAB0" />
    <WidgetStyle name="Active tab text" styleID="0" fgColor="000000" />
    <WidgetStyle name="Inactive tabs" styleID="0" fgColor="000000" bgColor="C0C0C0" />

As you can see, there is no fontsize = "" parameter and that needs to be added as follows.

To make the change, add fontsize= to each of the lines as follows.

    <WidgetStyle name="Active tab focused indicator" styleID="0" fgColor="FAAA3C" fontSize="14" />
    <WidgetStyle name="Active tab unfocused indicator" styleID="0" fgColor="FFCAB0" fontSize="14" />
    <WidgetStyle name="Active tab text" styleID="0" fgColor="000000" fontSize="14" />
    <WidgetStyle name="Inactive tabs" styleID="0" fgColor="000000" bgColor="C0C0C0" fontSize="14" />

Just another disclaimer; I found that making the changes in this post had no affect on the size of the texts displayed in the Notepad++ TAB Bar.

Quite honestly, I would like the text size of the entire GUI to be adjustable as the higher the resolution of a monitor, the smaller every thing becomes and Operating systems, including open source OSes such as Linux, do an extremely poor job of dealing with that problem. The end result is that as the quality of one's eyesight degrades, the more difficult it is for one to see what's on the monitor and to easily utilize one's computer.

What's worse, the harder it is for one to see what's on the monitor, the more one's eyes strain, and the more one's eyes strain, the more one's eyesight degrades.

As far as the magnifier tool that Microsoft put in Windows is concerned, that tool is a complete joke as it totally messes up the layout of the desktop every time it is started. After it is shut off, you have to go through and rearrange the desktop because it won't do that for you.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.