3

This question already has an answer here:

A few weeks ago, I inserted my pendrive into my college's PC to transfer my assignments, but it was not working. It was corrupted and was asking to format. I couldn't even copy files, and was forced to format.

After formatting, my pendrive's size was reduced from 8GB to 3.96MB.

Since then, I've been trying restore it. From diskpart to third-party software, Windows to Linux, watching several youtube videos, but nothing has worked.

I already have looked at this question, but nothing worked.

PS: I'm using 64-bit system to achieve restoration.

marked as duplicate by G-Man, Pimp Juice IT, user477799, DavidPostill Jun 4 '17 at 22:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

MiniTool Partition Wizard Free - worked for me.

I have an 8Gb USB flash drive that I'd previously formatted as bootable with MemTest95 on it. When I deleted MemTest95 and formatted it, it kept saying capacity was only 49Mb. I tried various solutions but none worked. Finally I recalled a great program I'd used in the past for creating partitions etc., and wondered if it would restore my USB Flash drive to full capacity. Thankfully, MiniTool worked a charm. Easy to use and fast.

Now have my USB Flash drive restored back to 8Gb. Very happy to recommend MiniTool Partition Wizard Free to anyone with this problem.

-1

Have you tried SD Formatter? While its designed for SD card it also works on USB flash drive. Another possibility is that, something wrong with the controller and in this case you'll need a "USB Production" tool to fully restore the capacity(and block possible bad sectors), however you need to find the exact tool for your flash drive and might not worth the trouble.

Not the answer you're looking for? Browse other questions tagged or ask your own question.