6

How do I identify what is my 'Intel Chipset' , on a Windows 7 Home Premium 64bit system?


This is actually a follow-up question to

USB 3.0 ports function as USB 2.0 ports on Windows 7 -- trying to fix via DeviceMgr & downloads from Intel website

The specs for my computer are: HP Pavilion dv7-6b32us Laptop Core i7 2670QM 2.20GHz, 4GB DDR3, 640GB HDD ,Win 7 Prem.

As suggested at the previous Superuser question-and-answer, I tried going to the Intel website via this link. (click to see)

There are 4 downloads being offered by the website, but how do I determine which of these 4 offered downloads is the appropriate one for me to download?

More to the point... how do I identify what is my 'Intel Chipset'?

I did find something called 'Intel Chipset Identification Utility' via

https://downloadcenter.intel.com/download/18498/Intel-Chipset-Identification-Utility

, but, it's stated as being only compatible with 32-bit operating systems. I am on Windows7-home-premium-64bit.

Many thanks for any help that can be offered in helping me identify what is my 'Intel Chipset'.


Status Report#1

Sigh... well, a slight update on the situation, and this corresponds to the preceding thread located here, too.

None of the ideas so far worked, despite spending HOURS trying to get the USB3.0 ports to actually operate at USB3.0 speeds.

I mention this as a warning to others that might be having a similar issue-- solving the problem could potentially eat up a LOT of time.


Status Report#2

Well, I haven't thrown in the towel altogether, but...

Pursuant to the answer provided by @Chris-C in this thread, USB 3.0 ports function as USB 2.0 ports on Windows 7 -- trying to fix via DeviceMgr & downloads from Intel website , I've discovered something terribly distressing.

Specifically, I was told:

NO USB 3.0 support on the Intel 6-series chipset

And, yes. I found out that my system uses a Generation-6 chipset.

Hopefully, people that have this similar issue can be made aware of this limitation by this post.

But... why did Hewlett Packard include USB3.0 ports (I know they're USB3.0 because they have a blue color to their interior) IN THE FIRST PLACE?? Seriously, if you can give me an answer (in a comment), please do!

As far as the underlying concerns go, I'm still not quite giving up. At least not yet.


  • 1
    You know, I tried the ideas suggested by @Tim and Misha256, (not that I'm any less grateful to Ayan of course) but I'm still not entirely sure what would be the valid download for me. Based on this screenshot, that includes the info from CPU-Z and the info from typing 'wmic path win32_pnpentity where "caption like '%Chipset%'" get caption' , which download seems appropriate? my.jetscreenshot.com/23333/20150701-aofz-623kb – MercWithMouth Jul 1 '15 at 4:04
  • I see your problem now. Your PC has a 6-series chipset. That means, if it does have a USB 3.0 controller, it won't be an Intel one. It'll be some other vendor. I see you have an HP PC. In this case HP will be providing suitable drivers from their support website. – misha256 Jul 1 '15 at 4:18
  • 1
    Hmm. @misha256 , well, I'm certainly glad for that info! Alright, let me give that a try -- going to the HP support site and hunting out the right downloads. Please keep an eye on this thread so that I can give you updates and/or describe more hurdles. – MercWithMouth Jul 1 '15 at 4:59
  • Sigh. @misha256 Yep. We definitely have a problem here. I did go to the HP website to seek out driver downloads. This is what I ended up seeing, as reflected in this screenshot: my.jetscreenshot.com/23333/20150701-tzgn-876kb So, any thoughts to what I should do now or which of them I should download? – MercWithMouth Jul 1 '15 at 5:19
  • 1
    Sigh indeed. But you're almost there. You need to find out who your USB 3.0 Controller VENDOR is. Go to Device Manager, find the USB controller (which might be yellow-banged, and might not have a proper name). Right-click on it, choose Properties, and find the 4-letter Vendor ID: i.stack.imgur.com/zP1EV.png. In my example that's 14E4. Then goto pcidatabase.com and search that Vendor ID. Then you will know which of the three drivers to download :-) – misha256 Jul 1 '15 at 9:21
5

See if this wmic command gives you the answer. I found the command at https://social.technet.microsoft.com/Forums/scriptcenter/en-US/ac769b90-6ad1-46d3-bca4-9141d715e99c/chipset-via-wmi.

wmic path win32_pnpentity where "caption like '%Chipset%'" get caption
  • +1 to you from me, even though I provided an answer too. This is by far the most elegant answer so far. – misha256 Jul 1 '15 at 3:40
  • Yes this is indeed a good solution. But its not working for my AMD 970 chipset! I guess for AMD chipsets the parameters must be different. – Ayan Jul 1 '15 at 3:55
2

how do I determine which of these 4 offered downloads is the appropriate one for me

Only the first two downloads are relevant (the 7-Series and the 8/9-Series).

Intel's installers will block installation if an unsupported platform/chipset is detected, so you're safe to just try both. One will work, the other will simply refuse to install ;-)

If you still want to know what chipset you have, grab this legendary utility:

http://www.cpuid.com/softwares/cpu-z.html

Run it, click the Mainboard tab, walla. Also, here's a chipset reference to help you look up names/codes if need be:

https://en.wikipedia.org/wiki/List_of_Intel_chipsets#5.2F6.2F7.2F8.2F9_Series_chipsets

UPDATE: If your system has an Intel 6-Series Chipset, and you do have a USB 3.0 Controller, it won't be an Intel one. Intel only started integrating USB 3.0 into their chipsets from Series 7 onwards.

So if you have a 6-Series Chipset, you'll need to consult your system or motherboard specifications to determine the USB 3.0 Controller VENDOR and find drivers from that vendor.

  • 4
    "walla"? voila. – Bob Jul 1 '15 at 7:08
  • @Bob I'm going to pretend I knew that all along and went with a phonetic spelling for fun... – misha256 Jul 1 '15 at 9:00
  • @Bob en.wiktionary.org/wiki/walla ^_^ – vaxquis Jul 1 '15 at 9:54
  • Actually, @Bob, as the Wiktionary page you linked to says, its "voilà", with an accent on the "a". – Scott Jul 3 '15 at 0:10
  • @misha256 Well, I managed to find out at least that I'm on a GENERATION-6 series system. So... what might be the appropriate download that corresponds to Generation-6-series? – MercWithMouth Jul 6 '15 at 0:41
0

You can use this little tool to get details of your system.

HWiNFO

Look into the Motherboard section of the tool to get the details you require.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.