I just got a Lenovo X1 Carbon and I am flabbergasted on dual booting -- having the record in the boot manager.

Cliff Notes

  • It came with Windows 8.1.
  • I shrunk the Windows partition (within windows disk management)
  • I installed Ubuntu via USB
  • The installation is good, but the boot loaders are wrong

Things I've tried:

  • I have BIOS in Both Legacy/EUFI mode, Legacy First
  • Using EasyBCD, adding an Ubuntu Record and Saving the "Deployment" (Did nothing)
  • Turned off Secure Boot (Wasn't on)
  • Quick Boot is still on (Does this matter? Shows Lenovo logo rather than the normal PC startup info)
  • Reinstalled Grub2 Bootloader (Successfull install via link)

The Only Way it Works

  • If I set BIOS to Legacy only, but then Windows won't work.

I don't care which boot loader runs, I prefer Grub but don't really care I just want the option to boot to either. Does anyone know what I can do? :)

enter image description here

  • "If I set the firmware to legacy only, but then Windows won't work." Yup. Either have it on legacy mode and install windows in that mode. Or use UEFI mode, boot UEFI mode and install windows that way. Either. No changing in between.
    – Hennes
    Jul 2, 2015 at 4:26
  • On your GPT disk you will find a 'system' partition (probably FAT32 formatted). Which boot loaders are present on that? Are they all added to the UEFI variables?
    – Hennes
    Jul 2, 2015 at 4:27
  • @Hennes that is depressing and I will cry. Here is a screenshot of my drive i.imgur.com/QRJI2eN.png
    – JREAM
    Jul 2, 2015 at 4:49
  • I am going to try using the boot-repair-disk, it appears you can install Ubuntu in Legacy or EUFI mode (help.ubuntu.com/community/UEFI)
    – JREAM
    Jul 2, 2015 at 5:23
  • I have solved it, 90% here is the solution on my X1 Carbon: ### In BIOS: - Disable Secure Boot - Change your Boot Order so that USB HDD - This is important otherwise Ubuntu will NOT boot in EFI mode or whatever you want to call it. - You can install Ubuntu this way, or if it's already installed follow these instructions from a live-cd or USB @ help.ubuntu.com/community/Boot-Repair - Next, after this go back into Windows and open BCDEdit -- and you have to Dink around with that and This part im stuck at.
    – JREAM
    Jul 5, 2015 at 7:24

2 Answers 2


I have solved it, here is the solution on my X1 Carbon with Windows 8.1 Pre-installed:

In Windows:

  • First, You need to Disable Fast Boot.
  • Open Control Panel and Search for Power Button.
  • You should see a few lists (they might not be expanded, so click the arrow on the right).
  • Look at the Shutdown Settings area.
  • You want to uncheck Turn on fast startup (recommended)
  • To do that, the box is grayed out so at the top click `Change settings that are currently unavailable. Then do it.

Step 1


  • Disable Secure Boot
  • Make sure the Boot mode is UEFI (It's that by Default unless you changed it)
  • Change your Boot Order so that USB HDD - This is EXTREMELY important otherwise Ubuntu will NOT install the boot record EFI mode, it will do Legacy.

Disable Secure Boot

You will probably get a "Non Secure" warning every boot, who cares. Disable Secure Boot

Make Sure Boot UEFI is Set

Make Sure EUFI is set

Next, Move the USB HDD to the TOP:


In Ubuntu

  • To Get into Ubuntu the only way if it's installed or not (With a live-usb or live-cd) you MUST have your USB plugged in and your BIOS to check for a USB at the top of the list (I mentioned this in BIOS
  • Now you must connect to the internet (Wifi for me, there are no ethernet ports on X1 Carbon).
  • You can install Ubuntu from this point OR if it's already installed follow these instructions using Boot-Repair https://help.ubuntu.com/community/Boot-Repair -- This will fix it since you are in the non-legacy mode VIA this USB. (Or I have simple instructions I used below)

Install & Run Boot-Repair

If you did NOT already install Ubuntu, you MIGHT not have to do this -- either way It's OK to do.

sudo add-apt-repository ppa:yannubuntu/boot-repair sudo apt-get update sudo apt-get install -y boot-repair && boot-repair

I ran the Recommended

enter image description here

IMPORTANT -- The Boot-Repair MIGHT tell you to enter a few commands. I did them, It was about 4 or 5 lines total.

After it's complete, Reboot!

Your boot from Grub will look like this: Grub Dual Boot

IMPORTANT: Do NOT Run EasyBCD and Deploy a new MBR, otherwise you have to REDO the Live-CD and Boot-Repair again. I do not mind GRUB 2 at all, I like it. However, if you choose to not listen -- Good luck! Let us know what you find!


  • BCD-Edit is nice to have, but I am not sure if using this caused problems or not since I already had Windows Installed and messed around with it too much. If you get GRUB loading you are DONE.

if the PC came preinstalled with Windows and it is capable of UEFI it will be installed using the UEFI method, ie. using the GPT and an efi loader instead of the MBR. It appears you installed Ubuntu via the old MBR method (BIOS seetting: "Legacy first"). Either reinstall Ubuntu or Windows but be sure to install both using the same system: both GPT + Efi System Partition or both using GRUB (or another bootloader of your liking) + MBR and DOS partition tables. As Linux is really strong in customization it might be possible to change to the other loader with mich cppying over other data and reconfiguring - much of a hack really.

  • I explained that it won't work the way he tries to make it work. The answer may not be the answer he want but I simply can't change it. And judging from "I am going to try using the boot-repair-disk, it appears you can install Ubuntu in Legacy or EUFI mode" I guess that he actually does NOT know that it won't work. As far as I understand he just thought he misconfigured. While this still being possible, even with correct config this won't run.
    – ljrk
    Jul 2, 2015 at 13:00
  • I did understand you. The problem is I cannot give him a reply HOW to solve the problem as THERE IS NO solution except what I stated: "Either reinstall Ubuntu or Windows". There is an EFI partition, yes, that's all good - but you can create as many EFI partitions as you want - it simply won't help as it won't be able to boot from MBR or EFI
    – ljrk
    Jul 2, 2015 at 13:15
  • I will delete my comments then. I have provided feedback. If you address my concerns then I can reverse my vote.
    – Ramhound
    Jul 2, 2015 at 13:56
  • Eeeh, AGAIN: How should I address the issue of it beingimpossible? That's not possible.
    – ljrk
    Jul 2, 2015 at 14:18
  • If the problem is he installed Ubuntu without updating the EFI partition, you can explain, how he acomplishes that. I would also agree thats the problem.
    – Ramhound
    Jul 2, 2015 at 14:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .