2

This is the error message after restarting when doing OS X update:

"Command Line Tools (OS X 10.10)" could not be verified. It may have been corrupted or tampered with during downloading. Click Uptade to download and check the update again.

When rebooted back, there's a OS X installation progress screen showing for 10 minutes, and when back on desktop an App Store notification saying that my update didn't get installed. I tried updating and restarting again a few times but still see the same error.

3
  • You picked the busiest day of the year. It's not really all that surprising.
    – Tetsujin
    Jul 2 '15 at 6:42
  • Corrupted updates can happen. Especially in a busy day like first few days of the update. I understand that. What actually surprises me is that Mac App Store doesn't provide a good UI to recover from this problem!
    – Hlung
    Jul 2 '15 at 9:35
  • I had a similar issue trying to get 10.10.4, the Command Line Tools, iOS 8.4 & iTunes all in one go, first day of release. I got lucky & a reboot fixed everything.
    – Tetsujin
    Jul 2 '15 at 9:37
1

Looks like the new version of Command Line Tool downloaded from App Store is corrupted. I had to download the same of the same version from Apple Developers Downloads page and install it manually.

Then open the App Store, go to Updates tab, let it update the app list a bit. And the Command Line Tool is gone because it's already installed. Now I can continue with my OS X update :)

1
  • I have been experiencing the same problem for the last few weeks, and it is no longer a few days after the update. I will try to download manually as you suggest.
    – SabreWolfy
    Nov 11 '15 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.