0

I am running ubuntu 14.04. Recently I am not able to update the apt source. When I typed "sudo apt-get update", the process is very very slow, in hours that not proceed. And the result is all "Ign" or "Err" except one get "Get:1 http://mirrors.aliyun.com trusty Release.gpg [933 B]". But my colleague's ubuntu 14.04 is ok with this command and it installs software or updates the source.

I've tried many source from officer to locally, but the result is the same.

How to solve this problem?

Append information:

  1. I've tried more than 5 apt sources ,but both failed to update or install.their ip or website I've tested and all is ok (ping or use web browser).Download debs from the source directly(wget) is ok.

  2. I run ubuntu in virtualbox and can access internet and the net is bridged to my pc's phyiscal net card. Two virtualbox run in my pc. Their configure of apt source is same,One can apt update and install,while one cannot.

  3. When I open a vpn in my pc,the questioned ubuntu can apt-get update and install,then I closed vpn,it cannot update or install.

  • 2
    Check you can resolve the sources correctly by doing a ping on each uncommented name in /etc/apt/sources.list. If that resolves to an IP ok (it may not respond to ping though), then try doing a wget to the URLs. – Smiling Dragon Jul 3 '15 at 3:29
  • @SmilingDragon: That's a potential answer. Why not post it as one and add a bit more detail? – Larssend Jul 3 '15 at 6:07
  • @geewee It didn't feel like a complete answer yet so I figured I'd wait until the original poster comes back with the results, if it's solid then I can write up everything in the one answer. – Smiling Dragon Jul 5 '15 at 20:33
  • @SmilingDragon as I appended in my question,thanks. – Ezio Jul 7 '15 at 2:11
0

I got the reason. Because netcard eth0's MTU is not sutable with ISP's.When I set eth0's mtu to 200, apt-get is ok. sudo ifconfig eth0 mtu 200

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.