1

Despite hibernation being enabled, my home PC does not show Hibernate on the power menu when there are outstanding Windows updates.

Background

On both my Windows 7 Ultimate work and home PCs I have enabled hibernation:

  • Control Panel\System and Security\Power Options
  • Change plan settings
  • Change advanced power settings
  • Sleep
  • Allow hybrid sleep

I double checked that I am setting this for the active plan.

I also set Hibernate as the default action as my Power button action

  • Control Panel\Appearance and Personalization
  • Customize the Start menu
  • Power button action > Hibernate

On my work PC when there are outstanding updates the Hibernation item appears in the Power action button sub-menu. On my home PC it doesn't. See screenshots below)

Is there an option I am missing?

Screenshots

Work PC power menu:

Work PC power menu

Home PC power menu:

Home PC power menu

Thanks

4
  • Hi @Mark C. Out of interest, what version of Windows 7 are you running at home? At your work place, I imagine you will be using something like Windows 7 Pro or Enterprise, whereas at home, Windows 7 Home or something like that? The reason I ask is, it could be that the Home edition(s) don't allow for hibernation when Updates are required (obviously confirmation needed here). Can you hibernate your machine when you don't have updates to install?
    – James
    Jul 3 '15 at 8:53
  • @James Taylor. Both are Windows 7 Ultimate 64bit. Yes without pending updates the Hibernate option is there as the default.
    – Mark C
    Jul 3 '15 at 9:09
  • I've popped an answer below because it was too lengthy to place in a comment, although this may not be a solution. When i've tested it, I will post and update.
    – James
    Jul 3 '15 at 9:27
  • @James Taylor. Thanks, unfortunately I'm at work now and can't access my home PC (ironically it's hibernated), but I'll test tonight.
    – Mark C
    Jul 3 '15 at 9:48
1

Hmm, that seems odd, I can't see why Windows Updates would disable access to Hibernate the machine (although saying that, I don't always understand my Microsoft does some of the things it does...anyway I digress).

Can you give this a try for me:
- Open cmd as an Administrator (Shift + Right-Click cmd > Run as Administrator)
- Type: powercfg /hibernate on

This should give you access to the hibernate option now (?). I'm just trying to see if, when I have updates to install on Win 7 Pro, I get the same issue.

1
  • Thanks toggling off and on with powercfg /hibernate off && powercfg /hibernate on did it, no idea why it was missing in the first place though!
    – Mark C
    Jul 9 '15 at 9:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.