2

I am using Windows 7 OS.
I have recently changed my Linksys smart router to an Asus RT-AC87U.
The router has an external HDD connected to it that serves as a file server and can be accessed from the local area network and from the internet as well.

With the Linksys, I was able to map the external HDD as a network drive and also as an ftp server over the internet.

When I connected my external HDD to the Asus router I realized that the ftp part is working (with a minor problem that I will talk about later), but I can no longer map it as a network drive like I used to. I can only access it from the network section. I want to map it, to see the available free space on it and for easier access.
The only option I have is if I map a specific folder from the external HDD as a share.

For example:
HDD name is My_Passport, a folder in it is called folder1
I can map \\RT-AC87U\folder1
I can not map \\RT-AC87U\My_Passport or \\192.168.1.1\My_Passport
With the Linksys I was able to map \\192.168.1.1\My_Passport and see every folder if I open it.

The other problem is, if a limited access user connects to the ftp server, he can see all folders even if he has no access to it.

example:
There are 3 folders: folder1, folder2, folder3 The created user has the following access:
folder1 - RW
folder2 - R
folder3 - NO
The user can see all 3 folders. With the Linksys, folder3 was hidden.

My questions are:

  1. Is it possible to map my HDD as a network drive so all folders will appear? If yes, how?

  2. Is it possible to make a folder disappear for a user who has "NO" access to it?

I have already thought of putting all folders into another folder so I can map it as a share, but than I lose the ability to add different access to folders since it is not possible to modify access for sub-folders.

Hint:
You can experiment with the routers menu from http://event.asus.com/2012/nw/dummy_ui/en/

3
+50

The simulator link is for the RT-AC66U, which is not the same as the RT-AC87U. The following procedure might therefore apply to your router (or not).

Try this :

  • Go into the Web-admin interface
  • Click "USB Application"
  • Click "Media Services and Servers"
  • Click "Network Place(Samba) Share"
  • Set "Allow guest login" to "On"
  • Click Apply.

If this does not work for this router model, you will need to telnet into the router and do some hacking on its Linux configuration files. This article will tell you how:
Customizing Samba on an ASUSWRT wireless router

5
  • This looks nice. I will try this as soon as I get home from work and give You some feedback. – Divin3 Jul 8 '15 at 21:37
  • So, when I turned the "guest login" to "on", the My_Passport did appear in the network and I could map it with ease. If You can update your answer with a short explanation of why does this share appears only when I disable user/password protection for the LAN, I will accept your answer. Also if You can, tell me if it is possible to bypassed this somehow and make the share appear with password protection. – Divin3 Jul 9 '15 at 16:01
  • It is necessary to lower security to share the hard disk. Otherwise, one needs to manually define the physical hard-disk itself as one share in the Samba configuration file, and define user accounts and their permissions on the share. I tried doing this in the Web-admin of the router, but the simulator hang every time. See a Samba config example here (although it still specifies "guest ok = yes" which is the same thing). – harrymc Jul 9 '15 at 17:17
  • I think You should add this to your answer. Thank You for the explanation. – Divin3 Jul 9 '15 at 17:21
  • Adding it to the answer will force me to go into too many details, and I don't know enough about that router to be sure of giving a correct answer. – harrymc Jul 9 '15 at 18:58
1

I just bought this router. The auto update function does not work. It told me that I had the latest firmware. Just to be sure i visited ASUS website and yes, there was an update. Updated it and everything vent fine. So I am just saying don't trust the auto updater.

8
  • oh i forgot to say what i was trying to do with this router. I want to attach the harddisk from the router as a harddisk in windows that i can connect to from anywhere – Test man Jan 15 '16 at 19:05
  • Are you having trouble doing this? If so, I can give you a few tips. – Divin3 Jan 15 '16 at 19:16
  • yes please. i have tried for days now – Test man Jan 16 '16 at 15:22
  • After plugging in your external HDD to into your routers usb port, go to http://192.168.1.1/cloud_main.asp and enable Cloud Disk. Than go: http://192.168.1.1/Advanced_AiDisk_ftp.asp and enable ftp. Your external HDD should appear, below. You can create usernames with different read/write rights for different folders to access the router or give access to others. By the username that you use to login the router will have full access. This is all you need to do. Next you can connect from your browser by entering ftp://<your IP> into the URL. You can also create a share in my computer. – Divin3 Jan 16 '16 at 15:56
  • the trickier part is if you have a dynamic IP, that means you need to create a DDNS in order to be able to access your router/HDD anytime even if your IP changes. Fortunately ASUS has a free option for this, but you can also find other options if you want. For the solution given by Asus, go to: http://192.168.1.1/Advanced_ASUSDDNS_Content.asp?af=DDNSName and enable DDNS select www.asus.com as server and create a free DDNS account. It will be something like [anything].asuscomm.com. If your router could connect to the DDNS, you will see the DDNS name on your routers starting page. – Divin3 Jan 16 '16 at 16:04
0

First of all, I'd try to update the firmware of the router to the latest version; check the ASUS RT-AC87U Drivers and Utilities Download page and check if there is a newer firmware version than the one you currently have.

2
  • The router has an integrated firmware updater that checks if there is a new version and installs it. It says it has the latest update: 3.0.0.4.378_5134-gefca797 – Divin3 Jul 6 '15 at 14:26
  • I've been messing around in the dummy interface on the link you provided, but I cannot find any way to configure it to work the way you want. :-( – Wayfarer Jul 6 '15 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.