0

I am trying to set the script execution policy in PowerShell.

But when I tried, I get:

PS C:\Users*> Get-ExecutionPolicy

Restricted

PS C:\Users*> Set-ExecutionPolicy RemoteSigned

PS C:\Users*> Get-ExecutionPolicy

Restricted

I tried to run in admin mode, but no difference.

1

First, make sure you run PowerShell prompt as Administrator, or the proper access to the registry key 'HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\ShellIds\Microsoft.PowerShell' will be denied.

Afterwhich, try setting it using-force, or set-ExecutionPolicy RemoteSigned -Force.

  • I ended up changing that registry by hand. – Colliot Aug 14 '15 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.