0

I'm trying to develop for Wordpress locally, but I can't even get WAMP to work.

I install it and start but it hangs on the orange icon with the message "server Offline".

I've tried changing the port it listens on from 80 to 8888. One thing I'm uncertain about is where and in which file I should be editing?

There's the httpd.conf file in both C:\wamp\bin\apache\apache2.4.9\conf and C:\wamp\bin\apache\apache2.4.9\conf\original and they have 80 in a few different places.

UPDATE: found how to fix the problem but don't fully understand. Running net stop WAS allows WAMP to start. I found the directions here and had red IIS by default starts with Windows 8. I guess I thought it would have been easier to find this on Google if WAMP never works on Windows 8 by default?

UPDATE 2: never mind it's not working again :( here are the error logs

[05-Jul-2015 11:50:56 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_intl.dll' - The specified module could not be found.

 in Unknown on line 0

[05-Jul-2015 11:50:56 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_ldap.dll' - The specified module could not be found.

 in Unknown on line 0

[05-Jul-2015 11:50:57 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_intl.dll' - The specified module could not be found.

 in Unknown on line 0

[05-Jul-2015 11:50:57 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_ldap.dll' - The specified module could not be found.

 in Unknown on line 0

[05-Jul-2015 12:07:00 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_intl.dll' - The specified module could not be found.

 in Unknown on line 0

[05-Jul-2015 12:07:00 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_ldap.dll' - The specified module could not be found.

 in Unknown on line 0

[05-Jul-2015 12:07:01 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_intl.dll' - The specified module could not be found.

 in Unknown on line 0

[05-Jul-2015 12:07:01 UTC] PHP Warning:  PHP Startup: Unable to load dynamic library 'c:/wamp/bin/php/php5.5.12/ext/php_ldap.dll' - The specified module could not be found.

 in Unknown on line 0

[05-Jul-2015 14:08:39 Europe/Paris] PHP Parse error:  syntax err

or, unexpected 'echo' (T_ECHO) in C:\wamp\www\test.php on line 3


[Sun Jul 05 04:50:56.884946 2015] [mpm_winnt:notice] [pid 100:tid 532] AH00455: Apache/2.4.9 (Win64) PHP/5.5.12 configured -- resuming normal operations
[Sun Jul 05 04:50:56.884946 2015] [mpm_winnt:notice] [pid 100:tid 532] AH00456: Apache Lounge VC11 Server built: Mar 16 2014 12:42:59
[Sun Jul 05 04:50:56.884946 2015] [core:notice] [pid 100:tid 532] AH00094: Command line: 'c:\\wamp\\bin\\apache\\apache2.4.9\\bin\\httpd.exe -d C:/wamp/bin/apache/apache2.4.9'
[Sun Jul 05 04:50:56.885945 2015] [mpm_winnt:notice] [pid 100:tid 532] AH00418: Parent: Created child process 2572
[Sun Jul 05 04:50:57.109714 2015] [mpm_winnt:notice] [pid 2572:tid 440] AH00354: Child: Starting 64 worker threads.
[Sun Jul 05 04:54:23.655588 2015] [mpm_winnt:notice] [pid 100:tid 532] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Sun Jul 05 04:54:25.671621 2015] [mpm_winnt:notice] [pid 2572:tid 440] AH00364: Child: All worker threads have exited.
[Sun Jul 05 04:54:25.687247 2015] [mpm_winnt:notice] [pid 100:tid 532] AH00430: Parent: Child process 2572 exited successfully.
[Sun Jul 05 05:07:00.824045 2015] [mpm_winnt:notice] [pid 5128:tid 528] AH00455: Apache/2.4.9 (Win64) PHP/5.5.12 configured -- resuming normal operations
[Sun Jul 05 05:07:00.824045 2015] [mpm_winnt:notice] [pid 5128:tid 528] AH00456: Apache Lounge VC11 Server built: Mar 16 2014 12:42:59
[Sun Jul 05 05:07:00.824045 2015] [core:notice] [pid 5128:tid 528] AH00094: Command line: 'c:\\wamp\\bin\\apache\\apache2.4.9\\bin\\httpd.exe -d C:/wamp/bin/apache/apache2.4.9'
[Sun Jul 05 05:07:00.825045 2015] [mpm_winnt:notice] [pid 5128:tid 528] AH00418: Parent: Created child process 5296
[Sun Jul 05 05:07:01.032475 2015] [mpm_winnt:notice] [pid 5296:tid 440] AH00354: Child: Starting 64 worker threads.
[Sun Jul 05 12:45:12.001476 2015] [mpm_winnt:notice] [pid 5128:tid 528] AH00422: Parent: Received shutdown signal -- Shutting down the server.
[Sun Jul 05 12:45:14.003754 2015] [mpm_winnt:notice] [pid 5296:tid 440] AH00364: Child: All worker threads have exited.
[Sun Jul 05 12:45:14.030760 2015] [mpm_winnt:notice] [pid 5128:tid 528] AH00430: Parent: Child process 5296 exited successfully.
  • Look at the apache error logs. They will provide the details you need to resolve this - it may not be a problem with the port number. – DavidPostill Jul 5 '15 at 7:57
  • @DavidPostill it's empty – Celeritas Jul 5 '15 at 11:35
  • Check all the other logs under your wamp top level directory. – DavidPostill Jul 5 '15 at 11:57
  • @DavidPostill something to do with IIS was screwing it up, please see updated question. – Celeritas Jul 5 '15 at 12:11
  • Please read Can I answer my own question? – DavidPostill Jul 5 '15 at 12:14
3

That is because both IIS and WAMP try to set up a server listening on port 80. Only one application can use a local port at a time.

You have two options:

  • Enable WAMP server to set up a server socket listening on port 80 by shutting down IIS service;
  • Change the listening port to another one, for example port 8080. You can do that by editing the httpd.conf file and then replacing all :80 occurrences by :8080. If you click the system tray icon, then Apache ▶ httpd.conf, it will open your default text editor (usually Notepad) with the correct httpd.conf file.
  • Hmm that's strange I tried changing the listening port of WAMP and it didn't work – Celeritas Jul 5 '15 at 19:43
  • Nope, tried replacing all 80 with 8080 in Apache httpd.conf and it still hangs on the orange icon (and yes remembered to restart all services). – Celeritas Jul 5 '15 at 19:48
  • Have you tried clicking on WAMP system tray icon » Apache » Service » Test Port 80? – MC Emperor Jul 5 '15 at 19:58
  • It says "your port 80 is not actually used" – Celeritas Jul 5 '15 at 21:01
  • all of a sudden it's not working again. I added the error logs to the original question – Celeritas Jul 5 '15 at 21:21
0

Are you actually using IIS at all..? If not, it may be worth unistalling thereby releasing port 80 for Apache instead and avoiding having to modify the httpd.conf file too much.

IIS is integrated in Windows 8.1, but requires to be added as optional Windows component, unless you use a customised installation media.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.