0

So I recently received a Lumia 520. How can I install music from my existing collection to Windows Phone?

Difficulty level: I don't have a Windows "host" for it. I've got Fedora Linux on my laptop. Ideally this shouldn't require round-tripping everything through remote servers a.k.a. the cloud.

0

UPDATE: I re-tested recently. Copying MP3s onto the phone using the GNOME file manager (nautilus) seems to work in Fedora 24, but not in Debian Jessie (older software).

The "Unknown artist" problem may also be fixed by moving the file - so using a third-party file manager app, you could force a rescan by renaming moving a whole folder at a time. This is not instantaneous. I've created a folder zzz-upload, so I can drop in several folders, then "select all" + move them into place.

If I use Debian Jessie to convert FLAC files to MP3s using SoundConverter, they appear as Unknown artist, Unknown album. This can be fixed by applying the MusicBrainz Picard MP3 tagger to the MP3 files. IIRC, Soundconverter was doing something strange with the tags e.g. doubling them up, so it's not too surprising. I haven't tried a more recent version of SoundConverter - if possible I prefer using something that allows more control over the encoding quality (there is no setting inbetween 128 and 192 kbits, where the LAME "medium" preset falls).


Rhythmbox can copy MP3 tracks to Windows Phone. Just drag-and-drop. (Tested with this phone and Fedora 22). Other music players are available, it just needs to support the USB MTP protocol. Thanks Reddit.

It looks like it skips copying tracks if they're already present. So hopefully you can quickly copy over newly added tracks, without having to select them individually.

Rhythmbox also has a Sync button when you're looking at the device. It will delete any sound files from the device that aren't in Rhythmbox. It doesn't list the files to be deleted (!), or support exclusions or reverse sync. Albeit files recognized as podcasts are handled separately.


CAVEAT After unplugging my Lumia 520, I can't open it again. It's resolved if I reboot (or kill all processes with mtp in their name and log out).

...actually this only happens if you used the eject button in Linux. It seems not to happen if you unplug it without eject / unmount / "safely remove".

...and actually right-click -> "mount" can get it working after eject+unplug.

...and now it's working without any workarounds, sigh. So that might be useful information too. Though what I should do is reproduce it & report a bug.


Do not copy tracks using the Linux file manager. The phone listed all the tracks under "unknown album". I.e. the file manager didn't supply any metadata (as required by the MTP protocol). You might guess I'd be happier if this option worked... but my prediction is it's not going to get fixed.

I also noticed Rythmbox transcodes FLAC files as required. (I have an MP3 codec installed from rpmfusion). Implication: you don't have any control over MP3 encoding, unless you run Rhythmbox on MP3s.

Another alternative might be to copy them onto a memory card using a card reader. Unfortunately I found this left some of my MP3s as "Unknown album", but it might work for some people. If desired you could copy them to internal storage, using a file manager app. The Microsoft app didn't let me copy folders. I found another high-rated file manager that worked though.

I understand there's very good reasons for phones to use MTP (instead of Mass Storage like a USB stick). Android phones uses MTP too. It lets them be mounted by Windows despite using the Linux filesystem ext4 internally. Mass Storage would force them to use FAT. It also avoids filesystem corruption (no requirement to "safely remove"), and allows the phone to access the filesystem at the same time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.