4

I run firefox on Debian. I made a clean install with no cookies, or no information input from my side. I've also disabled all mumboo-jumboo healthy and crash report tracking. I've disabled 'shared additional data' too.

At this time, there is no TCP connection to any website, then I leave firefox open at the 'create new tab'. When I turn off firefox, there are no packets too. When I turn it on, I see random TCP packets to websites I've visited (days ago) like 'duckduckgo' and 'cloudflare'. (I suspect they are HTTPS, since they are sent over TLS to port 443 of the respected servers).

Why? (The issue is also visible on Chromium)

migrated from serverfault.com Jul 5 '15 at 16:31

This question came from our site for system and network administrators.

  • 1
    Did you disable "Share additional data (i.e., Telemetry)" as well? – DavidPostill Jul 5 '15 at 16:57
  • Yes, added that in the description as well. – Slytael Jul 5 '15 at 17:13
  • Likely updating recent/favourite websites for the grid view / tab page. It is what usually shows instead of a blank page when you add a new tab. – Brian Jul 5 '15 at 22:25
4

I found the solution in a blogpost. Hopefully it helps someone.

Basically Firefox performs a number of prefetches against CDN networks (cloudflare and other), contacts google for a malware updates and contacts it's own services for addon blocklists and other security updates. These settings can all be disabled at about:config.

I tested the browser for an hour with these settings, and no side service was contacted, that I didn't expect.

Source: http://kb.mozillazine.org/Connections_established_on_startup_-_Firefox

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.