1

I want to edit some of the existing text but for the life of me I can't figure out how.

I,

  • click on the text tool
  • click into the image, which creates a text box, and type in my text
  • this will create a layer with the text that I typed
  • 99.9% of the time the text is created at the wrong place, so I have to switch to the move tool to move my text to the proper place

Now this is where the frustration comes in. I just can't change my text color any more (or at all, even without moving it). I can select the layer, click into the text box, Crtl-A to select the whole text, no problem. But when I change the color from the text tool box, and select "OK", the color area from the text tool box itself changed, but not my text.

enter image description here

I tried "the Layers window, right button on the text layer, choose "Text Tool" and it opens the initial dialog box to type text, where you can change it", but the result is the same.

Checking the answer from Changing the text color in GIMP, which says "A text layer has an icon like a capital T on a piece of paper", but mine is not. It's like this,

enter image description here

I try to "New" a layer myself, but I can't find an option to specify this is going to be a text layer.

Please help.
Thanks

$ apt-cache policy gimp
gimp:
  Installed: 2.8.14-1ubuntu1
  Candidate: 2.8.14-1ubuntu1
  Version table:
 *** 2.8.14-1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
        100 /var/lib/dpkg/status
2

The first method you describe should just work - if you are able to select the text, then the color should change on applying the changes. If all letters are to be of the same color, you can try to change the color on the tool-options dialog, instead of the hovering translucent text-box - that sets the global color for the layer.

Another alternative is that your image itself can't hold the colors you are trying to use - ar eyou using an indexed image (or grayscale)? If so, do your editing in RGB mode (Image->Mode->RGB), and convert to indexed just in the last step before exporting.

Layer modes other than normal for your text layer can also make the text color behave diffently than they should.

  • thanks a lot for your reassurance. I closed down everything and restarted from "File"->"New", and everything is working now. Didn't know what exactly went wrong, but I believe it could be one of the situations you described. Thanks. – xpt Jul 8 '15 at 1:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.