15

I can't make IntelliJ 14.1.4 act on the ctrl+alt+arrow hotkeys on Windows 7. I already disabled the Intel hotkeys and don't know any further.

9 Answers 9

18

I disabled the Intel HD Graphics Control Panel Service from loading at startup, Restarted and now it works fine.

enter image description here

1
  • 1
    You could also just disable the shortcuts in this graphics control panel, but yes, this service was definitely at fault.
    – techfly
    Mar 30, 2018 at 9:40
10

no need to disable IntelHDGraphics control panel (IHDGCP)

just disable shortcuts 1) right click IHDGCP icon in the tray 2) graphics options 3) hot keys 4) disable

thats it.

4
  • 1
    According to the accepted answer this does not work "The service does not release its hotkeys even after they are disabled"
    – DavidPostill
    Nov 24, 2016 at 10:30
  • 1
    on my side it works, so i decided to add painless way to this old topic as an alternative.
    – Eugene
    Dec 2, 2016 at 12:53
  • @DavidPostill, I just tested it and the accepted answer is wrong. disabling hotkeys fix the issue instantly.
    – Arashsoft
    Jul 11, 2018 at 15:30
  • In my case i go to Intel Graphic Command Center > System > Hotkeys, turn on and turn off again ("The service does not release its hotkeys" so turn on and off solved the problem for me.) Oct 10, 2020 at 18:42
7

The problem was the Intel HD Graphics Control Panel Service. The service does not release its hotkeys even after they are disabled. Disabling the service in msconfig.exe and restart solves the problem.

1
  • 1
    Strangely, for me just disabling the shortcuts seems to have helped immediately.
    – techfly
    Mar 30, 2018 at 9:41
4

Confirmed, on my machine disabling hotkeys did nothing.

Sadly I had no administration privileges for disabling that service on my machine. Other solution that works, is to change the hotkey from the original one to something relevant.

Source: https://communities.intel.com/thread/51399

Changing the hotkeys to something else will release the hotkeys so it looks as though the driver registers the hotkeys no matter what.

3

first, open Intel Hd Graphics Control Panel and go to Options and Support, then doing follow setting:

enter image description here

Manage Hot Keys: 
    Enable
  ✓ Disable
2

This program should show you is something else is handling the Ctrl-Alt-Arrow combination currently: https://www.donationcoder.com/forum/index.php?topic=18189.msg163170#top

Unfortunately, there doesn't seem to be a way of figuring our what program is handling it.

1

http://forum.tabletpcreview.com/threads/how-to-disable-screen-orientation-hotkeys-ctrl-alt-arrow.17069/

I found the solution here.

In Windows CTL + ALT + F12 opens Intel control panel. Go to options and disable hot keys.

This is how it looks, but I added more details. https://superuser.com/a/1198318/522926

If you need to enable hot keys back (note, CTL + ALT + F12 will not work), go to Start menu in Windows paste Intel Graphics and run one of these files: Gfxv4_0.exe, GfxUIEx.exe, Gfxv2_0.exe.

Intel Graphics

0

It is still the issue with Intel Graphics Control Center even with disabled state.

Best way to mitigate is to reassign the keys to Ctrl+Shift:

enter image description here

0

For Lenovo users:

I had the same problem on my Lenovo X220 notebook (Windows 7). The root cause was Lenovo application named: Lenovo Screen Reading Optimizer. This application also allocate CTRL+ALT+ARROWs combinations. Just uninstall this app. It solved this problem in my case.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.