0

I am not able to find solution for this been searching google for last 2 hours. I entered wrong password in Putty while connecting to my website server. I entered it wrong like 3 times i think. Now whenever i try to open connection in putty i get following message:

"Network error: Connection timed out". I also tried opening my website in chrome or firefox i get same message. How can i open my website again or open connection through putty again? I tried restarting my pc, resetting my router but nothing.

--> Also logged in to WHM and restarted -> SSH Server (OpenSSH) But still nothing.

  • 2
    is the server hosted by another company? if so, contact them for support. they likely have Fail2Ban or another system lock out your account after 3 incorrect tries in a limited period of time, after which the firewall just rejects all traffic from you. you can try back tommorow. most threshold based account locks are only temporary. – Frank Thomas Jul 6 '15 at 15:24
  • @FrankThomas - I tried to restart apache and ssh server. But still nothing. – NoviceMe Jul 6 '15 at 15:26
  • 2
    Fail2Ban adds IPTables rules to block you once triggered, and they should be removed after a period of time. These rules may target your public IP, or even your username (yes, IP tables can do that). restarting services on the host will not remove these rules. thats why you should contact support. – Frank Thomas Jul 6 '15 at 15:28
  • @FrankThomas - So we cannot access Fail2Ban? Only hosting company can? – NoviceMe Jul 6 '15 at 15:29
  • I wouldn't know. but they would. – Frank Thomas Jul 6 '15 at 15:30
1

Looks like you are banned from SSH, firewall might blocking you. Restarting SSH will not help because fail2ban reads auth.log and if there are failed authentication attempts more than certain amount, attempting IP address will be blocked by a new firewall rule.

You can telnet to port 22 from another computer to see if you are able to access SSH. Try:

telnet yourserverIP 22

If you see a blank black screen immediately which will probably also state it is OpenSSH Server, it means that other computer can access to SSH of your server. You can use CTRL + ] to escape and type quit to exit telnet.

You can use this other computer to SSH to your server and restart fail2ban (assuming it is fail2ban):

$sudo /etc/init.d/fail2ban restart

If this command fails to run, let us know what is the error message.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.