2

when i create multiple really large windows with opengl (2 windows, each of them 13440+1080 pixels) aero turns off resulting in animation tearing. The video card (W8000) has 4GB memory, so there should be enough video ram.

a) is there a setting anywhere that limits the maximum windows size under aero?

b) can i still activate double-buffered/vsynced rendering? enforcing blank-to-vsync or opengl triple buffering does not work

| improve this question | | | | |
  • run ProcessExplorer or ProcessHacker and look in the System Information Windows how much free GPU RAM you have when Aero turns off. – magicandre1981 Jul 6 '15 at 17:59
  • we checked with process explorer, (there are two cards) 2x4GB=8GB was reported but when the window opens and aero turns off, 1.5 GB are reported as used, so 2.5GB should be left over – Heiner Jul 7 '15 at 8:48
  • why do you need such a large window? What is your Monitor resolution. – magicandre1981 Jul 7 '15 at 17:52
  • We attach 14 monitors with Full HD (1920x1080) to a system for large-scale opengl effects system. building a single system is simpler and more cost effective than distributing across multiple computers – Heiner Jul 8 '15 at 8:28
2

Microsoft knows an answer to a similar qustion: https://support.microsoft.com/en-us/kb/2724530

This problem occurs when Desktop Window Manager attempts to display a desktop that is larger than 8192 pixels high or 8192 pixels wide. This exceeds the maximum allowable size for a DirectX 10 texture. (In Windows 7, the Desktop Window Manager utilizes DirectX 10.)

So in our situation DWM is disabled. We have to reconfigure the desktop to reenable it.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.