I have a GPT partitioned disk with 2 HFS+ partitions. I am trying to shrink the first partition.

things I have tried so far:

  1. use Disk Utility.app
    error: "The partition cannot be resized. Try reducing the amount of change in the size of the partition"
  2. use gparted from a knoppix live cd
    fsck (called by gparted) fails because while gparted can see the multiple partitions, there is no file /dev/sda2.

Any suggestions?

2 Answers 2


The issue is that the data is spread across the partition with the free space required to shrink it located in between data. There are a couple options (at least):

  1. iPartition by Coriolis Systems. Works flawlessly. It comes with a Lite version of their iDefrag, which can compact the data and move the free space to the end of the drive. I never tried gparted but I didn't see any positive results online using it for HFS+ on Macs. Not free.

  2. Clone the drive onto an external or something, and then clone it back to the original. I've never tried this but I've read that it basically puts all the data at the beginning of the partition, allowing you to use Disk Utility to shrink it.

  • Thanks, I ended up going with iDefrag to compact the drive, and then just used Disk Utility to do the partitioning.
    – cobbal
    Jan 10, 2010 at 8:06

Hey, it seems to be an overflow in the journal space. So if you want to shrink your device and you got this error, you can disableJournal once and enable it right afterwards.

If the verifyVolume is successfull, you can resizeVolume to the new Value.

If you need to repair your Volume, you should use your MAC DVD and boot installation and JUST CHECK the device from that point

Greetings and good luck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.