2

I'm trying to use Synergy to connect my home computer (running Mac OS) to my work laptop (Windows 7). The Mac is the server and the PC is the client. It works fine when the computers are on the same network, but most of the time I need the PC to be on a VPN which gives the error:

WARNING: failed to connect to server: Timed out

My guess was that our VPN/proxy server was blocking port 24800, so I followed this article that uses port forwarding to connect over a more commonly-used port like 80. My router wouldn't let me use 80 so I went with 21 (FTP). I'm still getting the time-out error. Does anyone know how to find a viable port on the client machine?

  • Synergy does not support proxies. It’s not HTTP, after all. – Daniel B Jul 7 '15 at 5:43
  • 1
    I doubt this has anything to do with proxies and more to do with your VPN being to aggressive in its routing or synergy not binding to interfaces correctly. Are you using IP addresses to configure your client or are you using host names or autoconfig? – heavyd Jul 7 '15 at 7:44
  • I'm using IP addresses. On the client I'm specifying [WAN IP of my router] port 21, which forwards to port 24800 on the actual Synergy server. – Rob Jul 7 '15 at 14:53
  • Have you seen this post on a sister site? unix.stackexchange.com/questions/9087/… – MariusMatutiae Jul 8 '15 at 10:11
-2
  1. Disconnect VPN
  2. Connect Synergy
  3. Reconnect VPN
  • This doesn't work for any corporate VPN (Cisco or Pulse). The only way is if you're using a Windows VPN and can enable split tunnelling. – Janac Meena Aug 29 '17 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.