I am trying to install OpenWRT on my Dlink router DIR-825 with hardware version B1. I have Firmware version: 2.06EU. and I when I try to upgrade Firmware and select the OpenWrt image file openwrt-ar71xx-generic-dir-825-b1-squashfs-factory.bin, I get the error

The uploaded firmware file may not be correct. You may have uploaded a file that is not intended for this Gateway, or the uploaded file may be corrupted.

If the uploaded file is correct, it is possible that the gateway may be too busy to properly receive it right now. In this case, please try the upload again. It is also possible that you are logged in as a "user" instead of an "admin" - only administrators can upload new firmware.

The Gateway will not be reprogrammed.

I really can't figure out what is issue here. I am using router as admin. I am only one using this AP. Please guide me if someone else have gone through some thing like this or have experience dealing with such issues.

2 Answers 2


I found this OpenWRT forum page, by Googling around.

In particular, at the very end a guy with your router states:

Then I booted vista on this notebook and setup the same ip config. I tried the standard d-link firmware upgrade without recovery mode from internet explorer 8 and it still did not work! The solution was, to also use the recovery mode (press reset for ~30s until power blinks orange), only then flashing the downloaded image openwrt-ar71xx-dir-825-b1-squashfs-backup-loader.bin did work. From there it was easy to sysupgrade to my own image.

Thank you! I hope this helps others that try this.

He took the last words right out of my mouth.

  • "Ain't googling great?" no need to be condescending.
    – Moab
    Jul 7, 2015 at 12:56

You need to flash the image using recovery mode. Read the OpenWRT Wiki page:


Note: Since original Firmware 2.05WW Build: 05Beta01 it is not possible to flash OpenWrt via the firmware update page. (worked on a B2 revision with Ubuntu's Firefox in 2.05NA and 2.06NA) It looks like Firmware 2.01EU behaves the same way. Please use the firmware recovery mode instead.

Instructions are also on the Wiki page:

  1. Get into the D-Link recovery console with the steps below:

    a. While powering up the router, press and hold the reset button until the power LED starts blinking orange (usually takes around 45 (forty-five) seconds )

    b. Set a static IP on your PC to

    c. connect to, mind the quirks!

  2. Click "Browse" and select your OpenWrt image file (openwrt-ar71xx-dir-825-b1-squashfs-factory.bin, this binary image is available in the Backfire 10.03.1rc1 download directory and above)
  3. Click "Update" and let router flash the image (don't worry if it reboots before it reaches 100%). The page should display "Device is Upgrading the Firmware" in blue letters with the current percentage in red (with an incompatible Browser it doesn't). Look at the screenshot at the end of this section.
  4. The router's power LED should blink orange during bootup, as soon as it stops flashing, you can connect to it
  5. Tip! Note that default DHCP will allocate on 192.168.1.x, which is different subnet to the address you allocated above. This is why you can't connect until you change your IP address.
  6. obtain new IP from the router via DHCP and follow firstlogin
  • 1
    @MariusMatutiae: It's always better to link to explicit documentation than one person's forum posts. Also, given I wrote some of the instructions on that Wiki page, I didn't exactly need to Google to get it.
    – qasdfdsaq
    Jul 7, 2015 at 10:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .