I am trying to uninstall VS2012 on my dev VM and have tried the following so far:

-Turned off Windows Defender completely -Disabled restore point creation in System Settings -Used the cmd prompt ...vs-premium.exe /uninstall /force -Deleted any extra c++ distributable packages

BUT the uninstall still hangs on "Creating System Restore Points.." Is there any other way I can make this happen?

  • 1
    Have you checked the installation log which contains more verbose information. Can you manually create a restore point? – Ramhound Jul 8 '15 at 3:25
  • @Ramhound I did create the restore point manually, however, the forced uninstall still tries to create it itself. I did solve the problem by removing all the tools and duplicate distibutable c++ packages until uninstall worked – Mutu Yolbulan Jul 8 '15 at 4:26
  • You should submit what you did as an answer then. You should know there are multiple seperate versions of the C++ redistributable though, so they were unlikely, duplicate installations. – Ramhound Jul 8 '15 at 10:44
  • @Ramhound You are right but I suspect it was one of the 77 components that caused the problem – Mutu Yolbulan Jul 10 '15 at 4:26

Since no other than @Ramhound responded and I fixed the problem, I thought I should post it as an answer. I couldn't exactly pinpoint what the problem was, but I have a good idea of the root causes. I followed these steps and successfully removed VS2010 and 2012 and installed 2013 successfully.

1) Removed C++ redistributable from Programs and Features. There were many versions of it including the same one for x64 and x86. Removed almost all of them.

2) Then I manually removed some of the extra VS tools that came with the initial install. I deleted about 7-8.

3) Instead of going straight to the forced uninstall, I ran a repair on the original setup file. I think this was the step that saved me after removing all the packages and tools from Steps 1 and 2.

4) Created a restore point manually

5) Turned off Windows Defender and the System Restore Point creation. I don't think this helped much to be honest as the uninstall still said 'Creating System Restore point'

6) Then I started the forced uninstall and it was successful.

A good place to start is removing all the unnecessary VS tools that you don't use.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.