4

I ran the 'disk cleanup' utility in Windows, and it found 80GB of temp files. This was fishy, since my disk is only 128GB and definitely did not have 80GB worth of temp files, but I let it run anyways because I figured the tool couldn't possibly be that stupid.

Lo-and-behold, my PC no longer boots into Windows. It now goes to Startup Repair (where my main drive is D:\ for some reason, instead of C:\), and it tells me

Boot manager failed to find OS loader.

Repair action: File repair
Result: Failed.  Error code = 0xa
Time taken = 4056 ms

Repair action: Boot configuration data store repair
Result: Failed.  Error code = 0x2
Time taken = 0ms

I ran chkdsk /R /X D:, but it found 0 errors.

I tried sfc /scannow, but it always gives me the error

There is a system repair pending which requires reboot to complete. Restart Windows and run sfc again`

even after following the steps here.

I also tried the follow commands, with no luck.

bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd
bootsect /nt60 ALL /mbr
bcdboot d:/Windows

bootrec can't find my Windows drive, and bcdboot gives me the meaningless error

BFSVC: Unable to load MUI file for BCD strings (2).

I also tried doing a system restore, but it tells me "no restore points have been created". Apparently the disk cleanup utility deleted those too (even though it said it would save the most recent one!)

I cannot afford to backup everything, reformat, and reinstall all of my software. Has anyone seen this before and been able to fix it?


[Edit] I finally got sfc to run using these commands

del d:\windows\winsxs\pending.xml
del x:\windows\winsxs\pending.xml
sfc /scannow /offbootdir=D:\ offwindir=D:\Windows

However, it told me

Windows Resource Protection found corrupt files but was unable to fix some of them.

Opening D:\Windows\logs\cbs\cbs.log, I only see two errors:

Doqe: Failed uninstalling driver updates [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
Shtd: Failed while processing non-critical driver operations queue. [ HRESULT = 0x8007049 - ERROR_NOT_FOUND]

I'm now completely out of ideas.

  • 2
    I have bad news. You likely have a disk that started to fail, or at the very least, has encountered a soft failure. I personally have never been able to solve a problem like this, when SFC refuses to work, and I have spend weeks trying to solve it. There is no telling what cleanup actually removed. – Ramhound Jul 8 '15 at 11:10
  • 2
    @Ramhound: I've run both Spinrite and chkdsk, neither found any disk issues; and SMART stats in the BIOS report only a small (normal) number of bad sectors, all of which were successfully relocated. The issue is clearly that disk cleanup deleted some critical files, not a failing disk... – BlueRaja - Danny Pflughoeft Jul 8 '15 at 20:32
  • 1
    Well I disagree, I have experienced similar failures, and eventually the hardware failure surfaced ( even when previously to that it passed with flying colors ) – Ramhound Jul 8 '15 at 21:30
  • 1
    @BlueRaja I have just experienced a similar failure. A suspicious 69GB of temp, which I asked the tool to delete anyway. On next reboot, same missing OS loader. How did you resolve this in the end? – Alveoli Jan 15 '16 at 20:53
  • 1
    @Alveoli I ended up having to reinstall Windows :( – BlueRaja - Danny Pflughoeft Jan 15 '16 at 20:54
1

I just encountered the exact same problem, tried everything, didn't find a way to fix this either, had to restore from yesterday's backup, which does allow me to get the system back up and running.

I suspect this problem may be related to the fact that I'm using Dynamic Disk partitions on the disk Windows is installed. The problem has nothing to do with disk error, it's pretty clear Disk Cleanup deleted something important from Windows installation.

0

Ok I reinstalled Windows, there was no other way. No hard disk error was ever reported, so it's definitely not that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.