1

I have this: Mediasonic HFR2-ASU3S2

I set it up with 4x 4tb drives that were meant for NAS, all WD drives.

Now when I plug in the Mediasonic HFR2-ASU3S2 I get a warning pop up asking me if I want to format the disk (4 times, I am guessing its one warning for each of the disks) I have loads of data on that as I thought RAID 5+ is the safest option so the data is safest there, please tell me how I can recover that data.

I have tried posting on their mediasonic forums but they didnt answer and then quietly deleted my threads.

I am a complete noob in this field so any links, softwares, suggestions etc are also most welcome.

Thanks in advance!

  • 1
    Do you happen to have a current, known-good backup of all the data? That would be easiest to start from. Or is this where you learn the hard way that RAID is not the same as a backup? – Andrew Morton Jul 8 '15 at 14:18
  • I thought having a raid was the same as having a backup... :( Sounds like this is going to be a bitter lesson – Ryan Jul 8 '15 at 14:25
  • There is still hope. The first thing to do is not use the RAID. I see that there is a button on the enclosure to select the RAID level - is there any chance that was pressed by mistake? – Andrew Morton Jul 8 '15 at 14:35
  • It's been a while since I have changed modes so I don't remember the exact procedure, but I think it's not so easy to just change the raid mode. If I remember correctly you have to select it in the front first then confirm it with another button at the back... so its a bit unlikely but of course possible. – Ryan Jul 8 '15 at 14:44
  • It sounds like the NAS itself has messed up, either through a hardware failure or software failure. I've never had to recover a RAID, so I am reluctant to give any advice other than read lots of articles on the recovery process. If you happen to have four empty 4TB disks sitting around, you could duplicate the current disks onto them so that any attempt at recovery can be on the duplicates, just in case it goes wrong. (more...) – Andrew Morton Jul 10 '15 at 18:24
0

Whatever you do, do not write anything to the disks, and certainly do not format them !

If all the disks have become unrecognizable at once, my first guess would be that the Mediasonic enclosure is broken. Your only hope is that while breaking down it did not destroy the disks. For lack of information about your computer, here is the general direction I would have tried in your case.

Try to take out one of the disks and set it up on another computer, or in another enclosure on the same computer, to see if it comes up as formatted or not. If the disk is accessible, make a disk image of it and repeat for the other disks.

If all the disks are saved, try getting the enclosure replaced, if still under warranty.

Otherwise, mount the images as virtual disks, trying out one or more RAID recovery products on these virtual drives. Here are some products I found on google, but more can be found. Some of them are commercial with trial, which at least will tell you whether the RAID is recoverable.

ReclaiMe Free RAID Recovery software (Windows freeware, verified as virus-free on VirusTotal)
Yodot RAID Data Recovery ($39.95)
EaseUS Data Recovery Wizard Professional ($69.95)
iCare Data Recovery ($69.99)

If you wish to do it yourself, here is how one person managed it. The programs he wrote for the recovery can be downloaded from the article: How to recover from a broken RAID5.

If the disks are unreadable, the situation is not good. You might need to use professional services, and these are costly.

|improve this answer|||||
  • No luck :( Any other suggestions? – Ryan Jul 17 '15 at 14:34
  • @Ryan How far did you get? – Andrew Morton Jul 19 '15 at 17:44
0

It appears that the Mediasonic is now presenting the drives as four independant disks as it's asking you to format four times.

I would agree with Harrymc but add R-Studio and UFSexplorer as other popular RAID recovery tools.

Also you may want to check the SMART status of the drives using a tool like CrystalDiskInfo. You may be dealing with failing drives or a bad sector situation.

I do a lot of NAS recovery work and in many cases the NAS manufacturer will use Linux software RAID (mdadm) under the hood. To check for this connect the drives to Linux and run... mdadm --examine your-data-partition

The good news is if the drives are sound data recovery from a failed RAID5 is almost always possible in my experience.

|improve this answer|||||
  • No such luck for me :( – Ryan Jul 17 '15 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.