1

im trying to install minimal Ubuntu Server 15.04 with X11 and functional KODI.

sudo add-apt-repository ppa:team-xbmc/ppa sudo apt-get update sudo apt-get install kodi xinit xorg xserver-xorg-video-ati

At this point, im able to run kodi with xinit /usr/bin/kodi

But when i try to run kodi with /usr/bin/kodi, here is the output:

user@htpc:~$ kodi Error: unable to open display Kodi needs hardware accelerated OpenGL rendering. Install an appropriate graphics driver. Please consult Kodi Wiki for supported hardware http://kodi.wiki/view/Supported_hardware

Glxinfo show same error

user@htpc:~$ glxinfo Error: unable to open display

Can anyone explain it to me, please? Even this isnt working Do I need install some other packages?

user@htpc:~$ DISPLAY=:0.0 kodi Error: unable to open display :0.0 Kodi needs hardware accelerated OpenGL rendering. Install an appropriate graphics driver. Please consult Kodi Wiki for supported hardware http://kodi.wiki/view/Supported_hardware

Thanks

  • Why not just install something like Kodibuntu and be done with it? – Larssend Jul 8 '15 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.