0

I am building a virtual network LAB using GNS3. It is installed in a virtual server (VMware) running Windows server 2012 Datacenter with 2 ethernet network adapters (Eth0 and Eth1), and 1 MS Loopback Adapter.

I want to be able to access (ping/traceroute) my GNS3 Router using my PC.

My LAN is configured as follows:

Network: 192.168.1.0

Gateway: 192.168.1.254

My PC: DHCP IP 192.168.1.215

And the server Hosting GNS3 is configured like this:

Eth0: Static IP 192.168.1.56, and it's sharing its internet connection with the loopback

Eth1: DHCP IP (Currently 192.168.1.163)

MS Loopback adapter: Static IP 192.168.137.1 (not a Typo)

The Cisco router on GNS3 has IP:192.168.137.2 and it's connected to the Loopback adapter. I am able to ping from the GNS3 Router to its host, the gateway and My PC, I can even ping IP address 8.8.8.8

I am not able to ping the virtual router from MyPC. I have added this static route to my gateway: Destination 192.168.137.0 255.255.255.0 gateway 192.168.1.56 and when i perform a traceroute from MyPc to 192.168.137.2 it reaches the host server but won't reach the loopback adapter nor the virtual router.

tracert output:

1    10ms   1ms   5ms   192.168.1.254
2   156ms   1ms   21ms  192.168.1.56
3     *     *     *     Request timed out
4     *     *     *     Request timed out
5     *     *     *     Request timed out
...

Is there anyway I can reach the loop-back adapter of the Server through MyPC?

Note: I've also tried disabling the loop-back adapter and using the Eth1 adapter instead. But i get the same issue.

0

This particular line:

Eth0: Static IP 192.168.1.56, and it's sharing its internet connection with the loopback

suggests that you enabled ICS on Eth0 with the loopback adapter. ICS uses Network Address Translation (NAT) on the interface that is assigned as the 'public' interface. Only the public interface (Eth0) is visible from the outside network, whereas the other one (loopback adapter) is hidden. To allow direct communication with the loopback adapter, disable ICS and enable IP forwarding on the guest OS.

IP forwarding can be enabled in Windows Server 2012 by going to the Registry Editor > HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters, and setting the value of IPEnableRouter to 1. You may have to restart the Server for this change to take effect.

You may also have to enable IP forwarding on` the host OS and create a static route to the 192.168.137.0/24 network.

  • Thank you. The machine is running on VMWare vSphere and I am actually able to ping the servers IP address 192.168.1.56 from my LAN but not the loop-back interface in it that I created inside the server. – Francisco Maass Jul 8 '15 at 23:34
  • @FranciscoMaass: changed my answer. – Larssend Jul 9 '15 at 13:10
  • Thanks! Just to verify if i got it right 1. Disable ICS (stop sharing internet from Eth 0 --> Loop-back) 2. Enable IP forwarding on the guest OS (Win Serv 2012) 3. Create routes on the guest OS 192.168.1.0 <---> 192.168.137.0 – Francisco Maass Jul 9 '15 at 17:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.