1

It's only the 'q' key that's not working with right shift, the left shift seems to be working fine with it. When I press q key while holding down the right shift, nothing prints on the screen. I tried other key combinations with right shift, the whole set of keys i.e alphabets and number keys are all working fine. It's a really strange behaviour, as it's only a single key combination. I'm using Windows 8.1 now. Any ideas what might be causing this and how possibly I could go about fixing it? Thanks

  • Sounds like it is reserved for some other functionality may be. Do you use any keyboard mapping tools – Dave Jul 9 '15 at 7:36
  • No I don't know much about these things, so I can safely say I don't use them. – Andy Semyonov Jul 9 '15 at 8:12
  • Can you try a different keyboard, just to confirm the issue is with keyboard or not – Dave Jul 9 '15 at 8:14
  • I tried a USB keyboard a few days ago, and that seemed to worked fine with my laptop. – Andy Semyonov Jul 9 '15 at 8:17
1

I can think of one possible explanation. It has to do with 'keyboard regional settings' and it comes to mind because I had dealt with a similar problem some time ago.

But... We'll get into that in a bit. First, let's try to make sure that "rshift+q" isn't as badly nerfed as we might be suspecting...

Idea#1

♦♦♦♦♦♦

Specifically, let's see if the "rShift+q" keystroke combination still seems to be nerfed if you restart Windows into DOS mode (aka, 'Command Prompt Mode').

All the information I'm posting here in the form of screenshots is copied from http://www.startupsmart.com.au/technology/something-to-try-if-windows-8-stops-working/2013120311292.html and from http://www.startupsmart.com.au/technology/how-to-boot-windows-8-or-81-into-a-dos-style-command-prompt/2014011011475.html

how to boot into safe mode dos command prompt on windows 8.1

Now that you're in DOS mode... Test to see if "rShift + q" is still nerfed.

Idea#2

♦♦♦♦♦♦

If not... then I have a good suspicion that your problem has to do with regional settings.

If memory serves right, while I was traveling a couple of summers ago, I had leant my laptop to a guy from Austria. Because his English wasn't that great, he needed to change the language settings for the laptop's keyboard.

Needless to say, he changed it back later.

However, when I took the laptop home with me, for weeks I would have a problem with my keyboard where maybe 5% of the time, certain things wouldn't come out on the screen as I thought I typed them, if they would get detected at all.

What I ended up discovering was that there was a 'hotkey combination', that would automatically switch the keyboard-setting to the foreign-setting for German, which was enabled on the laptop.

I disabled the hotkey, and things worked fine.

Since I don't have Windows 8.1, I can't speak to how to do this specifically, but you might want to consider exploring your system to find the setting.

Idea#3

♦♦♦♦♦♦

Ah, and lastly... If all else fails, there's a program that might help you determine if "rShift+q" is registered as a hotkey by some program on your computer.

It's Hotkey Commander, available at http://hkcmdr.anymania.com/ .

Hope this helps and good luck!

  • Thanks for such an informative post MercWithMouth, I tried your suggestions,first with HotKey commander software, I couldn't find a hot-key reserved for rShift+q in it. Then I went in to advanced settings and then command prompt to see if it was a regional-keyboard settings issue, but again it wasn't the case, Q couldn't be printed with rShift, all the all keys and key combinations worked just fine as they're Windows. I can't think it's a bad key, either q or rShift, because normal q key is working and Q could be typed with lShift, while rShift is working with the rest of the keys except for q – Andy Semyonov Jul 9 '15 at 8:11
  • Sorry that was probably not very nice of me, I've given it +1 now. :) – Andy Semyonov Jul 9 '15 at 8:43
  • >Then I went in to advanced settings and then command prompt to see if it was a regional-keyboard settings issue... Hmmm. No, that was a totally separate suggestion. Errr... specfiically, did you RESTART IN DOS MODE to test what rshift+q does when you're in there? Let me know – MercWithMouth Jul 9 '15 at 20:49
  • Yes, in Windows 8.1 you can access the advanced settings through charm-bar and then the Windows performs a restart and starts in DOS mode, from there you can make changes to the System. I did just that, and the q key didn't work with rShift there either. I can't understand what the issue is! q+rShift, that's all, that's not working, all the other keys are working fine. – Andy Semyonov Jul 10 '15 at 17:00
  • @AndySemyonov Yikes. Yeah, it does seem like some sort of keyboard issue. Maybe some sort of quasi-short-circuit within the keyboard? Possibly one caused by spilling a bit of coffee on the keyboard? At this venture, you should try plugging the keyboard into a separate keyboard to see if it acts up there, too. Similarly, also try plugging in a keyboard from another keyboard that works fine and see if it works on your computer. If it's really physical damage, you might consider getting a new keyboard (or not, since it's only 'Q'). I'd recommend the Microsoft Wireless Keyboard 3000 v2.0 myself. – MercWithMouth Jul 11 '15 at 11:34
0

The fault is with your keyboard.

What the actual fault is, we can't tell without looking at it, but as per my question in the comments on your OP, I asked if you could try another keyboard. Since the USB keyboard works fine, it shows the fault is not software but in fact hardware.

I would simply use left shift, an external keyboard or you could try and use a tool like Auto Hot Key to map the right shift and Q combination to the left shift and Q!

Something like

RShift & q::
Send {LShift}+q
return
  • Yeah you're probably right there, but it's strange for only one key to not be working and that too only in a combination with another key. – Andy Semyonov Jul 9 '15 at 8:22
  • I don't think mapping the rShift to left would be a good move as the former works fine with other keys except just for q. I'll keep the settings as they're and use lShift for capital q wherever need be. – Andy Semyonov Jul 9 '15 at 8:26
  • That's no problem. Since I don't know much about keyboard mapping, your post has made me rather curious about it, would mapping the rshift to lshift for q combination make the rshift work as if it were the lshift? – Andy Semyonov Jul 9 '15 at 8:36
  • I downloaded Windows Hot key commander as suggested in another answer. Would that work for mapping keys? – Andy Semyonov Jul 9 '15 at 8:45
  • A hardware fault means RShift+q wouldn't register at all and the computer does not receive the key stroke, why would it magically work with autohotkey then? On the other hand, if it works(very unlikely) then its a software issue. – Chris.C Jul 9 '15 at 9:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.