0

I have a Thinkpad x220 (Debian Stretch) with a 6 cell battery which seems to be ok, according the the xfce4-power-manager. xfce4-power-manager-settings.

The odd thing is that the battery drains during hibernation (to disk) at a very high rate (30% in 10-12 hrs).

I've tried to determine the cause and fully charged the battery, went to hibernation, removed the battery, reattached after 12 hrs and checked the remaining charge. It lost just 0.4% of the charge, which was probably used during the boot process.

What may cause such an awful battery drainage and how may I fix it?

edit: I've just tried to completely shut down the system, waited for ~5 hrs and lost another 5%. (I've now disabled WOL and AlwaysOn USB). I will try to update my BIOS and check if that changes anything.

  • Unfortunately, that's normal on a X220. It will drain the battery in a few days, no matter the power state. I've since given up on Lenovo. – Daniel B Jul 9 '15 at 10:15
  • Really a friend of mine also owns an X220, but never witnessed that behaviour.. – apoc Jul 9 '15 at 15:23
  • 1
    Are you running the latest BIOS offered by Lenovo? – Ƭᴇcʜιᴇ007 Jul 9 '15 at 15:24
0

The problem may be some hardware drawing power when the laptop is powered down. Common bits of hardware that do this are USB mice and keyboards and in-built wireless network cards.

A few things to check:

1) When powered down, is the mouse still active?

2) Open Device Manager
* For each hardware listed, open Properties
* Is there a `Power Management` tab?
* If yes, ensure `Allow this device to wake the computer` is NOT selected
* Click Ok (and move onto next hardware entry)

For the 2nd step, there will likely be dozens of hardware entries in Device Manager. Each check takes about 15s, so you'll need to budget about 5 or more minutes...be patient!

Another problem may be the network card itself. By default, modern network cards continue to draw power even when the laptop is "off". Refer to this Superuser question and answer for details.

  • Thank you for the hint. I have no periphery attached, so that's not the problem. I've disabled WOL and other settings for the network interfaces in the BIOS and it still occurs. Also, I do not use Windows. – apoc May 25 '16 at 13:05
  • Yes, I see you use Debian Linux. The problem may still be one or more bits of hardware drawing power, though the answer given applies to Windows and so needs to be slightly different! :o) Unfortunately, I do not know where to find device properties for hardware are in Debian. – AlainD May 26 '16 at 16:10
  • I've tested it with Windows as well and configured the devices accordingly, but the problem is still the same. thank you anyways! – apoc May 28 '16 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.