3

There is a issue with sending mails through Apple Mail (ver 8.2) every time I try to sending mail. The SMTP Part works fast, after a few seconds the Recipient get the mail but in Apple mail the progress bar ist still showing a status about 33%

I try to create a new Account on a fresh System and enter my IMAP / SMTP Server settings and the same problem occurs. It is possible that anything is wrong with the part copy Mail to sent folder or the smtp session for sending didn't closed right so that the next part (copy to send folder) can't initiated.

The Mailserver runs with Cyrus/Postfix the Client runs with latest Mac OS and Apple Mail Version. With other Clients like iOS Mail or something else there are no Problems.

Sequence of events:

  • start sending mail
  • SMTP Server accept connection and relay Mail to recipient
  • Recipient get mail
  • delay, delay, delay
  • copy mail to sent folder on server
  • message send progress bar closed
4
+100

In short: It's a Yosemite issue which was fixed in OS X 10.11 (to be released in October). If you have a Gmail account it is even worse.

FYI Details:

Sequence of events:

start sending mail SMTP Server accept connection and relay Mail to recipient Recipient get mail delay, delay, delay copy mail to sent folder on server message send progress bar closed

It's a part of Apple processing, not your server. Some say that this is time consumed by Apple to manage the user's iCloud & other devices updates but that is wrong because even without iCloud, and with only one device, you have this delay.

The best way to see deeper what Mail does during this delay: is to inspect the Console + Running something like WireShark. One alternative is to use another Webmail app like Thunderbird.

Note: The next OS X (El Capitain, v10.11) claims to make it 2 times quicker. https://www.apple.com/osx/elcapitan-preview/

| improve this answer | |
  • Sorry but use another Client is no option. The delay ist about 5 minutes per mail it is too long. It is a good hint to use wireshark. I will try it. – kockiren Jul 13 '15 at 13:02
  • @kockiren Obviously. 5 minutes is huge... Yosemite is a hassle for some others apps than Mail. Some guys reinstalled it to erase any slowing elements or caches. But it seems OS X El Capitain (the next OS X) has fixed it ... let's trust it. They say 2times faster (lol) apple.com/osx/elcapitan-preview/#performance. So they know they have a problem. I'm sure WireShark can help investigaing. A good test is to see if with a non-GMail account you get less delay. Have a good sharking – ArchiT3K Jul 13 '15 at 13:08
  • Okay I will download OSX10.11 and will check that it works – kockiren Jul 13 '15 at 13:12
  • It could be the bug, or it could be something else. I know it's very technical, but if you are up for it, you can download wire shark and monitor the traffic flow to see if it's really the application or something else. – Geruta Jul 13 '15 at 13:14
  • 1
    @kockiren any news ? – ArchiT3K Jul 15 '15 at 12:50
0

From Apple forums :

Possible two solutions were :

Use the "Network utility" tool in "Utilities" to use "Lookup" feature of the tool,

then type in your incoming POP3 email server to get it's IP address and do same for your outgoing SMTP email server to get it's IP address

Then go back to mail program, preferences, accounts and replace your incoming and outgoing mail servers with these ip addresses

If you were using gmail :

  1. Log into your Google Mail account on the Google Mail website

  2. Click Settings

  3. Click Forwarding and POP/IMAP

  4. Under IMAP Access, click Configuration Instructions

  5. Under Mail Clients click Apple Mail 3 (Leopard), even if your Mail is the later version

  6. Under "10" click "recommended client settings:

  7. Follow the instructions given here by making the adjustments shown while you are in your Apple Mail (Mail Preferences).

From Apple exchange :

From the Mail menu, click Preferences > Accounts > Mailbox Behaviors

Drafts:

Store draft messages on the server > leave unchecked

Sent:

Store sent messages on the server > leave unchecked

Junk:

Store junk messages on the server > checked Delete junk messages when

Never

Trash:

Move deleted messages to the Trash mailbox > leave unchecked Store deleted messages on the server > leave unchecked

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.