6

I have a web server that uses https protocol. I want to create a self signed certificate so I did the following:

  1. Issued this command:

    openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout mysite.key -out mysite.crt
    
  2. The copied both .crt and .key file to /etc/ssl/crt directory.

  3. Modified /etc/apache2/sites-available/webserver.conf which is my configuration file for apache and the web server. Here I added this 3 lines to the virtualhost:

    SSLEngine on
    SSLCertificateFile /etc/ssl/crt/mysite.crt
    SSLCertificateKeyFile /etc/ssl/crt/mysite.key
    
  4. Restarted the server.

After this I have tried and tried searching for a way to add the certificate to chrome but all methods either fail or are completely inacurate (this means that the tell me to search for options that are not there). This is usually because they are old posts and answers.

So now that I have done the above. What is the right way to add the exception to Chromium running on Debian (I clarify this because a couple of tutorials showed windows commands)

2
  • If the Apache side is working and service the cert you expect it to serve, then there's really no reason to include the Apache config stuff. If the Apache part isn't working, that's a different question, anyway, and there's still no reason to include the Apache part. Jul 10, 2015 at 15:34
  • I see no errors in the apache part. But since I can't get the client to work I added that information in cas it was necessary to solve the problem
    – aarelovich
    Jul 10, 2015 at 16:06

1 Answer 1

2

Doesn't chrome use the OS cert store?

sudo cp my.cert /usr/local/share/ca-certificates/
sudo update-ca-certificates

Restart the browser

Chromium's docs say:

certutil -d sql:$HOME/.pki/nssdb -A -t "P,," -n certnickname -i certfilename
1
  • I have tried the first two lines of codes. I get this Updating certificates in /etc/ssl/certs... 1 added, 0 removed; done. Running hooks in /etc/ca-certificates/update.d.... Adding debian:cmnbb.pem done. done. Nonetheless nothing changes as the https error NS error. I don't have certutil installed and could not find it in repository
    – aarelovich
    Jul 23, 2015 at 10:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.