2

I am using Windows 7 Home Premium, Service Pack 1. Looking at Windows Explorer, I have a folder with multiple documents (.doc, .xls, .pdf). I want to MOVE the documents into subfolders. (I know how to copy/move documents.)

1 -- I created 5 subfolders and tried to MOVE the documents into the various subfolders. Suddenly Windows Explorer will not MOVE the documents; it will only COPY them to a subfolder.

2 -- I moved ALL the documents onto a flash drive, deleted all of the folders/subfolders on the computer, emptied the recycle bin and started over. The same exact thing happens when I create new folders/subfolders and move the documents over from the flash drive into the subfolders on the computer. It will only COPY them -- not MOVE. A duplicate copy remains in the main folder. However, I never dragged/dropped the documents there -- I only put them into the subfolders.

3 -- I tried to CUT/PASTE the documents from the flash drive to folders/subfolders on the computer and the same thing happens. The documents go into the subfolders where I put them, but they are also automatically copied to the main folder.

Do you have any idea what is happening and what I can do to fix this?

5
  • 3
    This seems like a long shot, but is it possible that the Ctrl key on your keyboard is stuck? Holding Ctrl while dragging files forces them to be copied. – boot13 Jul 12 '15 at 16:14
  • I suspect the folder is a special folder, like a Saved Search. If you move files on the USB stick, will it move them or copy them as well (i.e., does it depend on the directory or volume you are using)? – user1016274 Jul 12 '15 at 16:39
  • 1
    Does you see a small + sign when you are dragging the file? That means it is a copy not a move. Using drag and drop to the same drive will move by default. Using drag and drop to a different drive will copy by default. The ctrl key will swap between copy and move – DavidPostill Jul 12 '15 at 16:42
  • Given that even with cut/paste the same happens, it seems windows is not allowing you to remove the files during the move action, which could be due to either a permissions issue (see right-click, properties, security) or a program is locking the files. I had a similar problem where it was the preview pane locking the files. I could move files if I had a selection of files as that doesn't invoke the preview pane. You should check for spyware/virusses too, just in case. – LPChip Jul 12 '15 at 20:54
  • When I want to move files, rather than copy them, I press the right button on my mouse, drag the files/folders where I want them, and when I release the right button, Windows gives me the option to either copy or move. I then click on Move, and Windows moves the files. – BillDOe Jul 12 '15 at 22:28
4

This happens because you’re copying from another device. By default when moving from another device, Windows copies the folder instead of moving them.

You said that you are trying to move from a USB flash drive to your computer - these are two different drives and copy is the default behavior for Windows for different devices.

Windows only moves the folder by default if it is the same device, like moving a folder from C:/Users/../Documents to C:/Users/../Pictures.

There is an easy shortcut to workaround this, which I use regularly.

  • Hold Shift while dragging to move the folder, even from another drive.
  • Hold Ctrl to copy, even if it’s on the same drive.
  • Hold Alt to create a shortcut to the file/folder.

Please note that there will be an overlay that tells you what you’re doing, that changes depending on whether you're holding Shift, Ctrl, or Alt. Watch me move a folder from the C:/ drive to the D:/ drive by holding the Shift key:

moving folder to another drive with shift shortcut

Edit:

In the third example you gave you said that you tried to copy and paste, but the folder still remained on the USB flash drive but also copied to the new device. In this case it sounds like you don’t have the proper permissions, that is, the device is read-only for example, or the folder is read-only. You can copy a read-only folder or files from a read-only device but if you try to move or delete the folder you can’t.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.