11

How could I do this?

I tried:

  1. putting the chromebook in dev mode
  2. enabling debugging options
  3. set the root password
  4. browse as guest(also tried with a google account)
  5. open shell ctrl + shift + t
  6. enter shell and sudo su
  7. enter password I set in debugging options window

Password is incorrect.

I tried also to recovering with Chrome extension, and after that normal mode was set again. Then I went back to development mode, did the same steps above. Getting the same result.

Any advice?

1
  • did you try just doing sudo su after logging into your Google account from within the Linux terminal?
    – Tommie C.
    May 11, 2019 at 16:49

4 Answers 4

12

Starting from the desktop, logged in as a user[1], the following steps have solved this problem for me:

  1. Press Ctrl+Alt+Forward Arrow (Ctrl+Alt+F2 on some machines. If your machine doesn't have F2, then try whichever key is two spaces to the right of Esc - typically it's an arrow facing to the right).
  2. You should reach a "Developer Console" prompt, where the last line of text ends with localhost login:. Enter "root" and hit return.
  3. Enter the root password you set previously (or just hit return if you didn't set a root password).

[1] It may be possible to reach this console without being logged in - I am not sure.

2
  • 2
    Strangely, the empty password for the root user does not work for me on VT2. I can type 'chronos' at the login prompt and the password I had set for it, and it works, but not for 'root'. Once I'm logged in as 'chronos', I do 'sudo su', type the chronos password, and I'm root. I try to change the root password with passwd, and it tells me 'Authentication token lock busy'.
    – fulv
    Sep 22, 2016 at 23:58
  • Good answer: it is required to a the text console (Ctrl-Alt-Fx) the first time because the chronos user doesn't have any password initially, meaning sudo doesn't work until chromeos-setdevpasswd has been used at least once.
    – MarcH
    Oct 18, 2019 at 3:30
1

I just spent several hours trying to figure this out. In particular, Ctrl-Alt-F2 (AKA '->') was only showing me a blank, black screen. However, it turned out that there was still a login prompt running (just not showing on the screen)!

I was able to log in as root and run the 'chromeos-setdevpasswd' command to set a password, just by blindly pressing the right keys and hoping it would work. It did!

I didn't see this possibility mentioned in any of my search results, so thought I'd put it here in case it helps anyone. I'm using an Asus C202S Chromebook, with CHROMEOS_RELEASE_VERSION=10895.56.0 (according to /etc/lsb-release)

1

1.) localhost login: root password: The password is the password you set for enabling debugging features.

For Example: If your password that you set is: 12345678 then it will look like...

localhost login: root
password:12345678

2.) Now it should say: localhost ~ # enter chromeos-setdevpasswd and press enter it will look like...

localhost ~ # chromeos-setdevpasswd
password:

now enter a password to use for sudo su. Then verify your password.

-1

I found this to set up root password for chronos. Android App Testing on Chromebooks February 28, 2019

Need to start from "setting up developer mode initial reboot".

1
  • 1
    Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change.
    – DavidPostill
    Jan 25, 2020 at 17:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.