1

I tried doing what the fellow at this site managed:

https://github.com/rajmenon/KB/wiki/Setup-a-ConEmu-task-for-posh-git--(w--Github-for-windows)

doing the same as he using the keybind in conemu results in

'`powershell' is not recognized as an internal or external command,                                                                                                            
operable program or batch file.                                                                                                                                                


Current directory:                                                                                                                                                             
C:\Users\c                                                                                                                                                                     

Command to be executed:                                                                                                                                                        
"C:\Windows\system32\cmd.exe" /C `powershell -noexit -command Set-ExecutionPolicy bypass;.$env:LocalAppData\GitHub\shell.ps1;.$env:github_posh_git\profile.example.ps1         


ConEmuC: Root process was alive less than 10 sec, ExitCode=1.                                                                                                                  
Press Enter or Esc to close console...  

'`powershell' is not recognized as an internal or external command, operable program or batch file.

typing just powershell in conemu results in a fine running powershell(x64) process, so I don't think this is a path issue. im on conemu 64 as well.

3

Looks like there are stray back-tick (`) characters in those instructions. They are used to delimit code blocks in markdown, but so is putting four spaces before the code on a new line. It looks like the author tried to do both.

The fix is to ignore those back ticks at the start and end of those commands.

`powershell -noexit -command Set-ExecutionPolicy bypass;.$env:LocalAppData\GitHub\shell.ps1;.$env:github_posh_git\profile.example.ps1 -new_console:a`

should be:

powershell -noexit -command Set-ExecutionPolicy bypass;.$env:LocalAppData\GitHub\shell.ps1;.$env:github_posh_git\profile.example.ps1 -new_console:a
  • well I should know better... but so should he :) thanks bud – 2c2c Jul 13 '15 at 1:11
  • Apparently editing that page is open to anyone, so I have removed the back ticks from the documentation to avoid future confusion. – Windos Jul 13 '15 at 1:12
  • apparently, the whole page is deleted? – kumar_harsh Jan 7 '16 at 6:44
  • @kumar_harsh looks like it was renamed: github.com/rajmenon/KB/wiki/… – Windos Jan 8 '16 at 3:10
  • alright, I've updated it in the question – kumar_harsh Jan 8 '16 at 7:43

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.