2

This is for recording a Google Hangouts call on my Retina MacBook Pro. I am using the internal microphone and the internal speakers.

I would simply like to record the conversation. So I would like to record my voice picked up by the mic as well as the voice coming out of my speakers.

My DAW is Logic Pro X.

I have followed the steps from this and this answer but they have not worked. The problem is that the internal microphone records the other person's voice coming from the speakers—even though Hangouts works perfectly. [Of course I could always use headphones as my output, which would not result in a feedback loop with the internal mic, but I much prefer to use the internal speakers.]

Reply to Tetsujin:

I just tried Audio Hijack and I am getting the same issue as using before from when I was using the Soundflower workaround in my DAW: the internal microphone picks up the speaker output which causes an ear-piercing feedback loop.

I've tried Audio Hijack with two different configurations and this issue persists.

Configuration 1:
Audio Hijack "Record Google Chrome Application" Configuration

Audio Hijack "Record Google Chrome Application" Configuration

Configuration 2: Audio Hijack "Record System Audio" Configuration Audio Hijack "Record System Audio" Configuration

  • Can someone upvote my question please? I am trying to add a screenshot photo but I can't since I don't have 10 reputation points. – Kyle Jul 13 '15 at 19:41
  • You're routing the mic straight to the speakers - no wonder you're getting howlround. Changing my answer... – Tetsujin Jul 14 '15 at 9:21
1

The prime app for any task like this has always been Audio Hijack* from Rogue Amoeba - not cheap though for a single task, $49.

I've not tried it for that specific task type, but there's a demo available. Though it injects periodic noise, it should be sufficient to test whether or not it's fully suitable for your intended purpose.

Rogue Amoeba took over Soundflower after Cycling '74 stopped maintaining it, but it hasn't really been updated & doesn't have anything like the functionality of Audio Hijack.

Tweaked answer after OP edits.

You need to not route the mic directly to the speakers, or you will get immediate howlround.
You will always get some spill of the audio from the speakers into the mic, which may make it sound more 'reverby' - the only fix for that is to use a headset - but it will prevent the mic recording itself, playing itself, recording itself… …

See this example -

enter image description here

*No afilliation, just a satisfied user

  • @Tesujin please see my reply to your answer above. Audio Hijack does not filter out the audio coming out of the speakers when recording the input. – Kyle Jul 14 '15 at 1:27
  • I have reproduced your session and can confirm success on my end. But, like you said, the echo issue has come to light, which is rather unpleasant, and turns every caller into a supermarket PA announcer. When making a call in Google Hangouts (or Skype, or any application designed for simultaneous mic and speaker use), my internal mic does not pick up the internal speaker output. Thus, no reverb. How does that work? (I know it's not a gate; I would guess it is some sort of filter of the output). Why can't "Audio Hijack" do this as well? – Kyle Jul 14 '15 at 11:21
  • When you're on a call, you don't hear it, but the other person will – Tetsujin Jul 14 '15 at 12:37
  • @Tesujin I ran a test where I was on a landline phone and the other person was on speakerphone and had speaker output in Hangouts. I did not notice any echoing/feedback of my voice at all. – Kyle Jul 21 '15 at 3:22
  • You're comparing apples to oranges. A speakerphone will have noise-suppression built-in. A microphone cannot, in & of itself, distinguish between 'wanted' & 'unwanted' sound. – Tetsujin Jul 21 '15 at 19:44
0

Soundflower still works- I've used it to record Google Chrome audio while listening to it. It doesn't normally inject periodic noise like Audio Hijack, but if it's set improperly it might make a very loud static noise.

  • Recording Google Chrome audio alone is simple. I am trying to record Google Chrome audio, plus the internal microphone signal at the same time. I cannot figure out how to get Soundflower to not self-record what the speakers are outputting and the internal mic is picking up. – Kyle Jul 14 '15 at 1:32
0

I wanted a FREE option, and this is what has worked for us:

  1. Install QuickTime for MacOS.
  2. Install the free version of iShowU Audio Capture. (iShowU is what the creators of Soundflower recommend since Soundflower isn't officially available anymore.)
  3. Mac > System Preferences > Sound > Output = "Multi-Output Device (Aggregate Device)"
  4. Mac > System Preferences > Sound > Input = "Aggregate Device (Aggregate Device)"
  5. Plug in your headphones, if you'll be using them. Remember that plugging/unplugging can cause the volume to set itself to different levels.
  6. Choose these settings: Mac > Audio MIDI Setup.app >
    1. Set "Built-in Microphone" to 1.0
    2. Set "Built-in Output" to 0.5 for both channels (1 and 2)
    3. Set "iShowU Audio Capture" > Input to 1.0 for all 3 sliders (Master, 1, and 2)
    4. Set "iShowU Audio Capture" > Output to 1.0 for all 3 sliders (Master, 1, and 2)
  7. Open QuickTime Player
  8. Choose to record new audio
  9. Here in QuickTime, using the drop-down menu arrow next to the red Record button, check that Microphone = Aggregate Device
  10. Press Record
  11. Use Hangouts to start a VOIP call, such as at https://hangouts.google.com/?action=chat&hl=en&pn=%2B19998887777
  12. In Hangouts, click the gear icon to see the settings (which unfortunately only seems to become available after starting a call).
  13. Ensure that in Hangouts settings Microphone = "Default - Aggregate Device...", and Speaker = "Default - Multi-Output Device..."
  14. When you're finished with your conversation, save the audio file.
  15. Play back the audio file in QuickTime or Audacity. [When we tried opening the m4a file in VLC, the voice of the other person on the call was basically silent (inaudible). It seems that VLC couldn't correctly play the file that was recorded in this way.]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.