I'm having a rather unusual problem on my installation which I can't find the answer. I created a new ssh key using ssh-keygen, and got it a passphrase. The key is working. Added to the hosts I want to connect, and when it asks for the passphrase, I type and it works.

So, as expected, I went to add it to the ssh-agent, but, this is happening:

ssh-add /home/[user]/.ssh/id_rsa
Enter passphrase for /home/[user]/.ssh/id_rsa:
Bad passphrase, try again for /home/[user]/.ssh/id_rsa: 

It does not accept my passphrase. I tried copy-and-paste, same deal. Anyone has any ideals?

1 Answer 1


In my case it was because I was trying to feed the key in Putty's .ppk format.

Exporting the key into OpenSSH format (e.g. via PuttyGen) and using that solved my problem.

  • Thanks for that info. I would give you a +1, but now I have to search how to do that.
    – VertigoRay
    Feb 5, 2018 at 14:19
  • 1
    Turns out it was really easy to do via PuttyGen. I moded your answer with that little detail. Thanks.
    – VertigoRay
    Feb 5, 2018 at 14:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.