3

I'm using Xfce4 with AwesomeWM (tiling window manager) - xfce takes care of updating, lets me quickly configure new monitor setups (dual head) and so on, while awesome is being awesome at managing windows with minimal configuration :)

The problem is - I still use a small Xfce panel to handle systray/notification area, and during loading some of the notification icons - Gajim, for example - show up in Awesome's notification area. Not a big problem, but it's on the part of one of the screens that I easily miss. After restarting gajim it ends up where I want it.

Now, if I autostart - let's keep Gajim as the example - Gajim via AwesomeWM config, it always ends up in Awesome notification area, while when started via xfce session management, it sometimes end up in xfce panel, but not always.

My guess is the loading order - so, how could I force desired loading order in xfce? Or is it some another probloem I haven't considered?

0

1 Answer 1

0

To avoid such problems you should stick to only one notification area. If you want to remove Awesome notification area, edit its config. By default, it's located at .config/awesome/rc.lua. If there is no such file, copy it from /etc/xdg/awesome/rc.lua.

Find the wibox settings block there:

    -- Add widgets to the wibox
    s.mywibox:setup {
        layout = wibox.layout.align.horizontal,
        { -- Left widgets
            layout = wibox.layout.fixed.horizontal,
            mylauncher,
            s.mytaglist,
            s.mypromptbox,
        },
        s.mytasklist, -- Middle widget
        { -- Right widgets
            layout = wibox.layout.fixed.horizontal,
            mykeyboardlayout,
            wibox.widget.systray(),
            mytextclock,
            s.mylayoutbox,
        },
    }

and remove or comment the line

        wibox.widget.systray(),

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .