0

I have an HP Gen8 microserver for home usage.

I use it as backup/replication and currently want to use it also home as media server.

I back up files using FTP, governed by IIS. Backing up on LAN connecting my PC directly to the 2nd Ethernet port of the server works like a charm, with Gbit speeds.

Unfortunately I found that the opposite is quite different. When I try to download, either via FTP or SMB any file I get speeds around 30kbps.

Server features:

  • Celeron CPU 1.8GHz
  • 2GB of RAM for now, waiting for next payroll :-) an upgrade
  • Windows Server 2012 Datacenter edition
  • Windows Storage Spaces RAID Parity Mode (4x2TB disks ==> 6TB volume)
  • No BitLocker or similar
  • Connection to Internet via Powerline 200Mbps adapter to home router
  • iLO port bridged on eth0 (please allow me some Unix speech)
  • eth1 bridged on eth0, in order to achieve Gigabit LAN

I have tried to download a movie via FTP over LAN, or SMB over Wifi (the server is Powerline-connected to the AP), bad results.

I would like to know how to tweak that bad performance. For instance, if I copy that movie file to a USB drive I get fast speeds, so it is definitely not a software-RAID problem (which should be slower in writing because of parity drive).

0

Eventually I found that the solution comes from this answer

The answer turned out to be the Large Send Offload (IPv4) setting on my NIC. It was enabled by default. When I disabled it my work upload speed jumped to 12+ Mbps. It appears that if the infrastructure (e.g. routers, switches) don't support this option the transmits become "bursty" and slow down. My home router (an Apple Airport Extreme) apparently does support this option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.