1

This question already has an answer here:

After a long search to find a solution to my problem I decided that maybe you guys can help me out. The problem is as follows.

I own an Asus N550JV laptop, running Windows 8.1, it has an Intel I7-4700-HQ CPU and a Geforce 750M as dedicated GPU. But no matter what I try, I can't get the laptop to use my GPU. I've tried updating the Nvidia drivers and forcing the laptop to use the GPU in the Nvidia software. My laptop is plugged into the wall and the Windows energy profile is set to 'High Performance'. I've also tried to change settings in the BIOS but all I can change is the Integrated Graphics allocated Memory size.

In the pictures below you can see the options in the laptop's BIOS.

enter image description here

enter image description here

I Hope somebody here has a working solution.

marked as duplicate by Samir, BlueBerry - Vignesh4303, DavidPostill, karel, Steven Jul 20 '15 at 15:10

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • What do you actually get/see to say it's not using the GeForce GPU? It's a laptop, the only video device is the GeForce GPU if you've got that spec... surely?! Can you post up a screenshot of the Display Properties / Device Manager of Windows so we can see what it's using instead (i.e. the Intel HD)? – Kinnectus Jul 14 '15 at 12:03
  • @BigChris That's not a CPU. It's an APU with HD Graphics 4600. – Samir Jul 14 '15 at 12:31
  • Have you tried updating the BIOS? – Samir Jul 14 '15 at 12:33
  • Thanks @sammyg, I should have checked the processor spec first! Additionally, if the laptop has an external graphics card (the NVidia) then, surely, like with a desktop, if an external card is plugged in (and working properly) then it should automatically disable the onboard? – Kinnectus Jul 14 '15 at 12:37
  • @BigChris It's a dedicated, embedded graphics processor, not an external graphics card. The term external is usually reserved for expansion cards. You don't have to disable the Intel graphics to enable Nvidia graphics. They can work in conjunction with each other. But unlike a CrossFire or SLI setup, they can't be used by the system as one. So you need a way to set a global system preference which one you want to use, and you do that in the BIOS if you have an option there, or in some control panel or utility software in the operating system. For Nvidia, that is Nvidia Control Panel. – Samir Jul 14 '15 at 14:49
2
  1. Right Click on Desktop
  2. Select nVidia Control Panel
  3. In left panel select "Manage 3D Settings"
  4. In right panel select Global Tab
  5. Under "Preferred Graphics Processor" select "Auto-Select" and hit APPLY button

Now try again and see if it properly selects correct GPU. If not

  1. Repeat steps 1 thru 3 above
  2. In right panel select "Program Settings" tab
  3. Under section 1., check the box for "only programs on this computer"
  4. then hit the "Add" button and find the program that you want to run on nVidia card
  5. Go down to section 2. and select nVidia processor

Source http://www.tomshardware.com/answers/id-2197694/switch-nvidia-intel-graphic-cards-k55vd-asus-laptop.html

Not the answer you're looking for? Browse other questions tagged or ask your own question.