14

Lately, I've been quite annoyed at the fact that I can't edit files in C:\Program Files\WindowsApps folder. I've used the takedown command, in elevated CMD, and changed permissions, to allow admins to have full control (I am an admin), and changed owner to Administrators. I can delete files/folders, yet, whenever I try to edit files, or add files, I get the error message "Access is denied." How do I enable creating files and editing files in WindowsApps?

0
12
+100

The WindowsApps folder is one of the most heavily protected folders in Windows 10. It contains all the Windows UWP apps, to which Microsoft zealously guards the access. The protections on this folder may change across Windows versions.

The usual methods of taking ownership and assigning permissions are not enough for this folder, but are still required as first step to gaining access. After executing them, accessing the folder is now possible for copying, but editing is still blocked. To edit, one needs to save the file elsewhere, and only then replace the original with the edited version.

A further note is that restoring the ownership of the folder to TrustedInstaller is possible without losing the extra permissions that were assigned, by using the command:

icacls "%ProgramFiles%\WindowsApps" /setowner "NT Service\TrustedInstaller" /t

If someone wishes to use an elevated Command Prompt for gaining access to the folder, then these are the commands :

    takeown /F "%ProgramFiles%\WindowsApps"
    takeown /F "%ProgramFiles%\WindowsApps" /r /d y
    icacls "%ProgramFiles%\WindowsApps" /grant Administrators:F
    icacls "%ProgramFiles%\WindowsApps" /grant Administrators:F /t

I also note that permission problems can be avoided by using the following commands before and after changing permissions to completely restore the original permissions :

icacls "%ProgramFiles%\WindowsApps" /save WindowsApps.acl
icacls "%ProgramFiles%" /restore WindowsApps.acl

To complement the poster's remark about restoring the original permissions on the folder while not having saved these permissions before starting, this is done by entering in an elevated Command Prompt (cmd) the command :

icacls "%ProgramFiles%\WindowsApps" /q /c /t /reset

If the command does not work, it needs to be redone from a Windows boot CD/USB, as explained in the post Reset default ACLs for C:\Program Files\WindowsApps:

  1. Follow the instructions on this page to create the Windows Installation Media
  2. Boot from the USB/CD, click "Repair my computer" upon reaching the Install button
  3. Select Troubleshoot, then Command Prompt
  4. Your current drive C: will be the boot media, with your Windows system disk likely in D:, so verify using dir D:, and if not, then search for the right drive-letter
  5. Using the drive letter you just found (maybe D:\), issue the command:

    icacls "D:\Program Files\WindowsApps" /q /c /t /reset
    
  6. Wait for the operation to complete, and check the output for errors

  7. Reboot.
16
  • Interesting, in my case "The usual methods of taking ownership" already gives me the right to change and create files/folders (Windows 10 Pro). In what specific case isn't it enough? – Albin Oct 9 '18 at 9:25
  • 1
    @Albin: It's not enough since Windows has built-in protections specially for this folder that can only be worked around, not removed. – harrymc Oct 9 '18 at 9:40
  • @Albin Maybe you are not using Windows 1803 or 1809, because these version don't allow any file edits even when you have taken complete control, I will test these steps asap. – Gizmo Oct 9 '18 at 10:13
  • @harrymc I just checked, I'm using version 1803 on my testsystem. I also double checked, I tried to edit and save an (exiting, not created by me) xlm file. It works without problems. – Albin Oct 9 '18 at 10:21
  • 1
    So I tested by just using icacls /save then icacls reset then icacls /restore but that made the apps unusable too. Something is getting broken / not restored. I'm stuck in figuring out how to make the apps work again after gaining access to the folder, even without modification. I do have developer mode enabled so I should be somehow able to launch the apps outside of WindowsApps folder, I just don't know how.. but developers should be able to test their apps, right..? I ran all commands from a "Trusted Installer" CommandPrompt (RunAsTi64) because running it from admin wouldn't work. – Gizmo Oct 9 '18 at 22:01
3

Level of difficulty [extremely advanced].

On Win 10 (almost latest version), I read Harry’s original post and chose to start with the backup:

  1. Click Start

  2. Type “cmd” and wait, don’t hit enter yet.

  3. Click “run as administrator”

  4. Type:

     cd \Progra~1 and hit enter
    
  5. Backup permissions:

     icacls "%ProgramFiles%\WindowsApps" /save WindowsApps.acl
    

I then continued with Harry’s guidance:

[Still]...an elevated Command Prompt for gaining access to the folder (but for grant I started with just my App, which had special settings it wanted me to update for EyeTV 64-bit):

takeown /F "%ProgramFiles%\WindowsApps"
takeown /F "%ProgramFiles%\WindowsApps" /r /d y
icacls "%ProgramFiles%\WindowsApps\GENIA...<-your App name" /grant Administrators:F
icacls "%ProgramFiles%\WindowsApps\GENIA...<-your App name" /grant Administrators:F /t

I was conservative I changed view settings: Select View > Options > Change folder and search options. Select the View tab and, in Advanced settings, select Show hidden files, folders, and drives and OK.

I then followed Albin’s post above to get more control and remove inheritance (not completely, but make it individual) on WindowsApps:

![Albin’s post images]

I now right click WindowsApps folder in C:\Program Files and unhide and uncheck read only.
Also gave myself, Admin, Full Control see Albin for permissions, and Apply

Then at elevated cmd:

icacls "file" /setowner "NT Service\\TrustedInstaller" /T /C

I went to my Genia folder in WindowsApps and copied the file I wanted to desktop, edited it and copied it back to just the Program Files folder (with Administrator confirmation).

Back in elevated command prompt I deleted the old file I wanted to change: del “filename.ini”.
Then I got Linus Torvalds Git app for windows, from wikipedia I Installed git-bash, then ran that “right-click” as administrator.
Copied the file using that and got a 0 byte empty file and error, but it did not break my apps, and proved write capability.

I got Ubuntu 12 and used Rufus in Freedos/mbr mode to make a bootable USB from Ubuntu AMD 64 or 32 iso, and BIOS boot to my UEFI USB.
In test mode I used The folder icon > Win10 “whatever your disk is called” to mount my drive.
In logo icon (top left), search terminal, click and navigate via:

cd /media/Win10/Program\ Files > enter
cat filename.ini > WindowsApps/GENIA.../Transponders/filename.ini

I unmounted (ejected) Win10 back in folder view. Shutdown (top right button), reboot.
Wait for dots about ten times.
Remove USB when prompted, hit Enter.
Test it out in Windows.
My App now works right, with settings updated.

I tried elevated cmd prompt:

icalcs %ProgramFiles% /restore WindowsApps.acl

No success, so I did:

icacls "%ProgramFiles%\WindowsApps" /q /c /t /reset

I then followed Albin’s post above to remove control and inheritance on WindowsApps:

![Albin’s post images]

Even though it was there, Made myself owner again. I Added Administrators > check Names.
Added new user permission, check names;
Gave myself just read & execute, list folder contents, read on a second Administrator entry;
And deleted full control entry for me.
I changed owner back

NT Service\TrustedInstaller > check names
Becomes TrustedInstaller

I then hit apply and close out.
My apps still work.

1

I have solved this myself nonetheless:

From an administrator command prompt the following command will copy the WindowsApps package folder (or any folder within):

robocopy /B /E /COPY:DAT D:\WindowsApps\xxx D:\MyTargetDir

This will copy the WindowsApps\xxx package folder on D:\ to MyTargetDir folder on D:\. This works because the /B option tells Windows to use the Backup token which ignores any permissions or limitations / policies.

After that the files need to be decrypted:

cipher /D /S:D:\MyTargetDir

Then the files can be edited.

Remove the original folder (or rename it):

mv D:\WindowsApps\xxx D:\WindowsApps\xxx_

And then copy back the edited files:

robocopy /B /E /COPY:DAT D:\MyTargetDir D:\WindowsApps\xxx

HOWEVER: Note, I still haven't figured out how to make the edited app start, as for now Windows Store will return errors for the apps in these folders as soon as the permissions are changed. Changing them back won't work.

9
  • How did you're WindowsApps-Folder change from "C:\Program Files\WindowsApps" to "D:\WindowsApps" in comparison to the original quesiton? – Albin Oct 9 '18 at 9:06
  • @Albin you can go to Settings -> Storage -> Change where new content is stored -> New apps will save to to separately install a new app on for example D:\ so experimenting is possible without destroying your original WindowsApps folder. – Gizmo Oct 9 '18 at 9:51
  • ah, ok, I thought you managed to move the whole WindowsApps somehow. In Order for the store not to show errors you need to restore the metadata of the files (like security settings etc.) to the original values then it should work without any errors. Using DAT as copy parameters doesn't copy "all" of them, so you need to reapply them or use different copy parameters (look here) – Albin Oct 9 '18 at 10:16
  • Yeah I copied DAT specifically so it wouldn't interfere with editing the files at the copied location because DATSU would also restrict editing. – Gizmo Oct 9 '18 at 11:12
  • I see, but then you have to reapply the security settings of the files (and possibly whatever other metadata gets lost during copying) in order to get rid of the error (anyway I like you're approach, very creative). Maybe you could try to copy the files with all the matadata and then try changing the ownership manually via UI or Commandline? What happens if you try to access the files after the change? – Albin Oct 9 '18 at 11:18
1

There is a solution: you have to change the ownership of the files/folders. Here you can see the description including screenshots (there's already a copy on superuser as well). I just tried it on Win10 Creating/Editing/Deleting Files is possible.

If you want to reverse the ownership change you can find a description here. After changing it back you're user will still have access to the folder, removing all other security changes (like changed permissions) that were made during the ownership change will fix that to it's original state.

Important: In some cases the Store (or the Apps) wont function after changing the ownership and changing it back, unless you remove "all" changes not just the ownership. So make sure to create a system restore point unless you know exactly what you are doing!


Here's a copy of the description to change the ownership:

  1. Type in C:\Program Files\WindowsApps in the Windows Explorer address bar and hit enter.

    Enter path

  2. Observe in shock and dismay the system dialog saying you don’t own a folder on your own machine. Hit "Continue."

    Denied

  3. After hitting "Continue," you’ll be confronted by the following dialog:

    Denied again

    Do not hit "Close"—instead click the "security tab" link.

  4. In the following system dialog click "Advanced."

    Properties

  5. Click the "Change" link in the owner security field.

    Change

  6. Add in your Live ID or Windows 8 user name to the "Select User or Group" system dialog.

    Add user

  7. Click "OK," "OK," and "OK."

    Done

9
  • 2
    This is not an answer to the question as this does not work. You seem to assume that the WindowsApps folder seems to honor the ACLs, which it does not (entirely). Download "Chess Free" to for example D:\ so you don't screw up your real WindowsApps folder. Do your steps and you won't be able to edit the game files. I will only give ab ounty to a solution that successfully allows me to edit files. Or even just copy them to my own desktop. This answer does not work for that. Copying a folder from WindowsApps to Desktop will yield (on a single pc not connected to a domain) and error. – Gizmo Oct 9 '18 at 7:29
  • @Gizmo what do you mean by "download Chess Free for example D:\"?? Changing the ownership allows me to create new Files/Folders as well as edit existing Files/Folders or copy them to the desktop etc. That's what you want to do, right? If it doesn't work for you, could you please explain what happens after you apply this solution and, for example, try to create a Folder or File in "C:\Program Files\WindowsApps" (or any subfolder)? – Albin Oct 9 '18 at 8:36
  • @Gizmo I'm unable to check reproduce you're problem. This method allows me to edit existing files (previously existing to the change) as well as adding new files as well as copy existing files to a different location. Could you please specify you're problem? What exactly is the error message? Thank you! – Albin Oct 11 '18 at 15:38
  • 2
    I keep getting "Access is denied". – Gizmo Oct 11 '18 at 19:32
  • 1
    My account has "Full Control" of all objects (via inheritance) – Gizmo Oct 12 '18 at 9:41
0

Simple alternative solution

I got tired of fighting the NTFS file/folder permissions in Windows a few years ago.

They aren't technically advanced. Neither should they be. Simple flags in the filesystem metadata plus rules configured in the OS.

Simple things made complicated and annoying by bad management tools and nerfed admin accounts.

Less annoying read/write access

  • Most Linux distributions have full NTFS support by now.
  • Most also ignore NTFS ownership/access rules when running as a Live OS
    (from USB or DVD/CD).

Linux Mint

Note:
USB thumb drive is required for the steps below.
It's contents will be overwritten.

Linux Mint is one of many distros you can download and use for free.

  • Simple and intuitive for Windows users.
  • Normal Desktop and "Start Menu" interface. Screenshot
  • Full FAT32 and NTFS support.

How?

  • Download an ISO from the official site
  • Download a tool like Rufus or unetbootin
    Then use it to write the ISO your USB drive.
  • Reboot your computer with the drive plugged in.
  • Hit the key to show boot menu or BIOS/UEFI, then select your USB as boot device.
    Which key depends on the computer OEM/Series/Model.
  • When you see the Mint desktop:
    • Open the drive.
    • Modify files/directories as you want.
    • Shut down/reboot in any sane manner.
  • Revert BIOS/UEFI changes (if you made any) and boot Windows.

Not simple?

If you never used Linux or booted from USB, it may seem a bit intimidating, but it's really not that bad.

If you keep Linux Mint on the USB, then rebooting to make changes can be done in a few minutes the next time.

Such a USB is also a great tool if (when) Windows stops working some day.
Perhaps after updates etc.

It could be used to copy files from un-bootable computers, or to repair/fix what ever made it un-bootable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.