I am trying to create a Tails Live USB via the Tails Installer on a 64GB usb key. I can successfully run Tails from a temporary USB key, but I run into trouble on the last step of Tails Installer > Clone & Install > Select Target Device > Install. Before I start installation, the right capacity (~62GB) shows up within the Tails Installer UI. However, once I hit Install and confirm, I get the output below:

USB drive found
Partitioning device /dev/sdd
Formatting /dev/sdd1 as FAT32
Verifying filesystem...
Setting /dev/sdd1 label to Tails
Not enough free space on device.
4231MB ISO + 0MB overlay > 2495MB free space
LiveUSB creation failed!
Not enough free space on device.
4231MB ISO + 0MB overlay > 2495MB free space 

It seems that after the Formatting, Tails thinks there are only 2.4GB of space on the USB key. Indeed, If I boot into Windows after Tails fails, the key shows up with only 2.43GB of space. Below are the USB key details after the Tails formatting process (details taken from the DISKPART utility in Windows): in the image below, the USB key is Disk 2


I have read about the known issues with USB sticks on the Tails website but my stick (SanDisk Ultra Fit 64GB USB) doesn't fit any of the listed models, plus the issue I face is not a startup issue as highlighted on that page.

Any ideas?

2 Answers 2


it looks like you try to install Tails on the same device from which you run Tails...?

according to the tutorial you can only install Tails onto another USB or SD card!

  • No @DJCrashdummy, it's not the same device. I am running Tails off a 8gb USB (it was unplugged when the DISKPART image grab above was taken). The drive from which Tails is running does not show up as an available target device in the Tails Installer UI, so that mistake is not possible. Jul 15, 2015 at 17:40
  • i'm not sure if this is still valid, but some time ago i read that the tails-installer (especially for a persistence volume) needs a GPT partition table! - and it seems your USB key does not... Jul 21, 2015 at 11:09

I resolved the situation by creating the Tails Live USB on another computer. I used the same two USB key as before: the source that contained the non-persistent tails (8gb key) and the large key on which I was trying to install a persistent volume (64gb).

The cloning worked several times on the 2nd machine, so the problem was not with my USB key but some quirk of the first computer. It could be that the USB port on that computer was to blame; I think it may have been a USB 3 port; I know for a fact that the successful operation was conducted on another computer from a USB 2 port. I would really like to re-try the first computer from a different port, but I have since lost that computer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .